SRCDS Steam group

Another Mani Admin Question
I wanted to install Mani Admin and followed the tutorial here and read the one that comes with the Mani Admin Plug-in (I run srcds on a Windows box). I put all the files in their respective server directories, made sure that exec "mani_server.cfg" was in my server.cfg file, bound a key to the "admin" command (made sure the key was not bound to anything, etc.) I also set myself up as an admin (using the tutorial on here and the name/password convention).

Not only can I not access the admin menu, I don't even think Mani is running on the server. I watched my map change in the server console and every single Mani Admin plugin command was preceded by the words "unknown command."

I'm no genius or tech expert, but I don't think the plugin is running at all. Any ideas why? I double-checked my install (files and locations), and the only difference I found was that in the latest version of Mani, the content of the mani_admin_plugin folder includes these:


--And is missing this one: quakesoundlist

The file list in the Mani tutorial are these:


I don't think these differences are the issue--any help would be appreciated. One thing--do I need to shut the server down and restart it after install(yeah--I know, dumb question, but it did not say I had to do that in the Mani Manual--is a server re-start just assumed?)
Yes, it will only load any plugin to the server on server restart. It is assumed basically because you will have to restart the server after installing any plugin at all. Theres ways of loading a plugin without a restart, but restarts are much easier.
plugin_load              : plugin_load <filename> : loads a plugin
plugin_pause             : plugin_pause <index> : pauses a loaded plugin
plugin_pause_all         : pauses all loaded plugins
plugin_print             : Prints details about loaded plugins
plugin_unload            : plugin_unload <index> : unloads a plugin
plugin_unpause           : plugin_unpause <index> : unpauses a disabled plugin
plugin_unpause_all       : unpauses all disabled plugins

you could use plugin_load to load a new plugin for the server. But here are all the SRCDS plugin commands regarding to addons folder files.
lol.. its easier just to type "exit" lol Toungue
skeletor Wrote:lol.. its easier just to type "exit" lol Toungue

Thanks guys. Been trying out some admin mods to see which one I liked. I did get Mani running after all.

As I may have said before I run a dedicated stand-alone server running SRCDS on Windows. I run SourceMM on it as well as VIP Mod (with no problems at all).

I've tried running Mani and also Basic Admin Plugin (not a the same time--one at a time). I liked Basic Admin Plugin a lot due to it's simplicity, but after installing it on my server (yes, I checked that it loaded in metamod and I can see it running in console) it crashes my server at map change every single time. I get the following error in a pop up box:

srcds.exe--Application Error
The instruction at "0x00e42723" referenced memory at "0x118e00e4". The memory could not be "read".

However, this same exact crash error happened with both Mani and BAT. Since it's the same crash error for both Admin mods--it's got to be some server setting. Any ideas on what it could be? I'd like to run an admin mod but thye both make my server tank on map change. Anyone ever see this?
hmm.. thats a very general error, and the most common one. Also its the absolute hardest one to fix. It could really be anything. One easy way I got around it on one of my older boxes was to disable virtual memory. Thats about the only thing I have ever gotten to sucessfully help it at all.
Basic Admin may be conflicting with Mani, I would remove it and just stick with mani. Mani can do whatever you need it to do.
I am having the same problem with mani. at first I installed it in the dedicated server directory which apparantly did nothing. Tried binding "a" to admin, added my steam ID to the adminlist file....I then installed many in the normal c strike directory and it started to initialize all of the mani files before the game new what was happening. It's like I have a corrupt mani file or something. I really don't trust the supplied documents cause they don't expalin anything in detail.

well I'll be constantly checking this and other boards so any help would be greately appreciated.

Forum Jump:

Users browsing this thread: 1 Guest(s)