SRCDS Steam group

Custom Sounds DL Maps do not
I recently bought some webspace to host custom maps and sounds for my server. The sounds download fine however it gives the error "missing map" when you try and download a custom map. All the folders match. The worst part is, the map downloads then it says its missing.. Any help would be great. -Adam

Server ip:
when it says the map downloads, is it actually in your maps folder after it says it downloads? Make sure that the map names and folder names have the same caps, because if the webserver is linux, it matters. Like make sure its not Maps on the webserver if its maps on the gameserver. Or the other way around. Other then that make sure its allowed to download the maps, and that the folder structure is the same as on the gameserver.
The files are all the same. It looks like the map downloads but it does not. The web server is windows aswell as the game server.


sound, game server:



does the map actually download? is it in your maps folder after its "done downloading" cuz even if the map doesn't actually download, it will still usually go through the whole process of looking like its downloading.

Also are you sure your webserver allows remote hotlinking like that? Most free webhosts won't allow it. Just seeing as you said you bought it, I'm guessing its a decent webhost, lol. One more thing, is that it may not recognize the file format bsp, so it doesn't allow it to download, you could contact your webhost, and ask them about it. They may be able to help a lil.
Lol net_maxfilesize 64 if I am correct?

jackaL Wrote:Lol net_maxfilesize 64 if I am correct?

thats only when downloading from the game server, when using sv_downloadurl is ignores the max file size.
Naw, Cause when I had my downloadurl, it still wouldnt let me. I had to change that and it worked Big Grin

jackaL Wrote:Naw, Cause when I had my downloadurl, it still wouldnt let me. I had to change that and it worked Big Grin

Psh. when I had one of my old surf servers, there was a map that was like 50 mb big, and it downloaded with sv_downloadurl, and I never changed my net_maxfilesize.
what is this "net_maxfilesize" setting, i dont use that.

yes I pay for this hosting. 5GB storage 250,000MB transfer.

No the map does not actually download, it just looks like it does.

Im going to contact my web host and see about not allowing the bsp file format.
Well, just try that, and see if it works Big Grin

My webhost says they need the full MIME type including extensions and applications that this file type uses. I know what they are talking about but I cant find the mime type for bsp and ain files.
lol, Well I haven't heard that one yet.. and I have no idea what the MIME type of a bsp file would be...
Just for future notice the MIME type is "application/x-srcds". My webhost did not support it, I sent them an email and they added it. Problem fixed.
alright.. ill keep that in mind if the problem comes up with anyone else. thanx for letting us know

Forum Jump:

Users browsing this thread: 1 Guest(s)