SRCDS Steam group

[CSGO] Public IP problem
I just downloaded the CSGO Dedicated Server and host a game. Only problem, I'm the only one that can connect, my friends can't. That's because the IP is my local IP which is This is not the IP address from whatismyip website.

So how do I change the IP to my real IP so everyone can connects?

You must use port forwarding to redirect all traffic on port 27015 (or other) to your local IP adress.
There is lot of tutorial who explain it on this forum: - Free games and Mumble servers
Thanks for the reply. I already port the needed ports but still the same.

As you can see I already forward all the ports
Ok, this look fine with port forwarding.
Be sure you use the "Dedicated Server Tool" and and not only click on "create a server". I think it's ok with that.
Be also sure in your server.cfg and startup command line you have set sv_lan to 0.
You can also try to use your public ip in your startup command line.
Can you copy paste your command line options ? - Free games and Mumble servers
server.cfg already I check, it has sv_lan set to 0

My command line option to start the server :-

srcds -game csgo -console -usercon +game_type 0 +game_mode 1 +mapgroup mg_active +map de_dust2
Try with adding +ip your.public.ip.adress in your command line - Free games and Mumble servers
If I add my IP to the command line, the server will not be successfully created. It will give a warning of NET_OpenSocket and at the very bottom will say Could not establish connection to Steam servers.

Forum Jump:

Users browsing this thread: 1 Guest(s)