SRCDS Steam group


[CS:GO] Failed to connect to remote server
#1
I've tried every possible solution. +ip -ip +net_public_adr.
Everything. I have forwarded the ports but every time someone else tries to use rcon they get "Failed to connect to remote server error". Since i host it my own pc i can use it through console but the only odd thing i noticed is 15:14:22: rcon from "90.190.xx.xx:59267": command "say yay" is that the port is random all the time i restart the server.
my startup commands atm C:\csgo\srcds.exe -game csgo -console -usercon +game_type 0 +game_mode 1 -tickrate 128 -autoupdate -maxplayers_override 12 +map de_dust2 -tickrate 128 -autoupdate +ip 192.168.1.68 +net_public_adr 90.190.xx.xx +port 27015
Reply
#2
Hi there, oalaro!

I'm a little bit confused over, what your problem actually is, but the failure of the console: "Failed to connect to remote server" can be fixed in many ways! It can be the steamlib, settings or even the downloading or installing process that bugged when your tried to setup the server. I would recommend to re-install your server.

Then the next thing you're talking about:
"is that the port is random all the time i restart the server. "
If you're running more than one server on your PC at the time, then the first server you launch will take the port "27015" as standard, then the next server you launch will take the port "27016" and then the numbers will just grow until you head the maximum port on your router which is: 65535. You can bind your servers launcher to a specific port by given it "+port 27015" in the shortcut then the server will always focus the port: "27015" and if the port is already in use then it will choose the next higher port available.

Then it could also be the IPv4 there are changing. Everytime you're logging on to your home network you connect your computer to your router and your router gives you an IPv4 adress so you can surf on the internet and actually be online. It can change if someone already have your previously IPv4 address, then you'll just take a new one because, it dosen't really matter. The IPv4 addresses is only so the router can handle all the different request from each PC. That's the difference between a router and a hub by the way beacuse, a router can handle each PC where the hub only can handle basic signals. Okay, but you can set your PC to focus an IPv4 address as you could with the server and the ports. You'll just have to set your DNS you the IPv4 you want.
For more help, just hit me:
Steam: bilbodog
Skype: bilbodog2
Facebook: http://www.facebook.com/bilbodog2

And don't forget to +rep [Image: NET-5.png]
- Best Regards bilbodog (Casper Thomsen)
Reply
#3
(04-14-2014, 08:56 AM)bilbodog Wrote:  Hi there, oalaro!

I'm a little bit confused over, what your problem actually is, but the failure of the console: "Failed to connect to remote server" can be fixed in many ways! It can be the steamlib, settings or even the downloading or installing process that bugged when your tried to setup the server. I would recommend to re-install your server.

Then the next thing you're talking about:
"is that the port is random all the time i restart the server. "
If you're running more than one server on your PC at the time, then the first server you launch will take the port "27015" as standard, then the next server you launch will take the port "27016" and then the numbers will just grow until you head the maximum port on your router which is: 65535. You can bind your servers launcher to a specific port by given it "+port 27015" in the shortcut then the server will always focus the port: "27015" and if the port is already in use then it will choose the next higher port available.

Then it could also be the IPv4 there are changing. Everytime you're logging on to your home network you connect your computer to your router and your router gives you an IPv4 adress so you can surf on the internet and actually be online. It can change if someone already have your previously IPv4 address, then you'll just take a new one because, it dosen't really matter. The IPv4 addresses is only so the router can handle all the different request from each PC. That's the difference between a router and a hub by the way beacuse, a router can handle each PC where the hub only can handle basic signals. Okay, but you can set your PC to focus an IPv4 address as you could with the server and the ports. You'll just have to set your DNS you the IPv4 you want.
I have a static ip. The port witch i use to connect is 27015. But when i use rcon on my machine(i host it on the same pc). It gives me something like this
L 04/17/2014 - 15:49:45: "Console<0><Console><Console>" say "work"
L 04/17/2014 - 15:49:45: rcon from "90.190.xx.xx:59767": command "say work"
Why is it rcon from 90.190.xx.xx:59767, cause rcon should use port 27015, not some randomly assigned port. I highly doubt there's something wrong with the install, but i'll reinstall when i have some time.
Reply
#4
(04-17-2014, 10:55 PM)oalaro Wrote:  
(04-14-2014, 08:56 AM)bilbodog Wrote:  Hi there, oalaro!

I'm a little bit confused over, what your problem actually is, but the failure of the console: "Failed to connect to remote server" can be fixed in many ways! It can be the steamlib, settings or even the downloading or installing process that bugged when your tried to setup the server. I would recommend to re-install your server.

Then the next thing you're talking about:
"is that the port is random all the time i restart the server. "
If you're running more than one server on your PC at the time, then the first server you launch will take the port "27015" as standard, then the next server you launch will take the port "27016" and then the numbers will just grow until you head the maximum port on your router which is: 65535. You can bind your servers launcher to a specific port by given it "+port 27015" in the shortcut then the server will always focus the port: "27015" and if the port is already in use then it will choose the next higher port available.

Then it could also be the IPv4 there are changing. Everytime you're logging on to your home network you connect your computer to your router and your router gives you an IPv4 adress so you can surf on the internet and actually be online. It can change if someone already have your previously IPv4 address, then you'll just take a new one because, it dosen't really matter. The IPv4 addresses is only so the router can handle all the different request from each PC. That's the difference between a router and a hub by the way beacuse, a router can handle each PC where the hub only can handle basic signals. Okay, but you can set your PC to focus an IPv4 address as you could with the server and the ports. You'll just have to set your DNS you the IPv4 you want.
I have a static ip. The port witch i use to connect is 27015. But when i use rcon on my machine(i host it on the same pc). It gives me something like this
L 04/17/2014 - 15:49:45: "Console<0><Console><Console>" say "work"
L 04/17/2014 - 15:49:45: rcon from "90.190.xx.xx:59767": command "say work"
Why is it rcon from 90.190.xx.xx:59767, cause rcon should use port 27015, not some randomly assigned port. I highly doubt there's something wrong with the install, but i'll reinstall when i have some time.

Yeah. Try to re-install and see about the issue still appears. Smile
For more help, just hit me:
Steam: bilbodog
Skype: bilbodog2
Facebook: http://www.facebook.com/bilbodog2

And don't forget to +rep [Image: NET-5.png]
- Best Regards bilbodog (Casper Thomsen)
Reply
#5
(04-18-2014, 02:00 AM)bilbodog Wrote:  Yeah. Try to re-install and see about the issue still appears. Smile
Reinstalled, still the same problem.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)