SRCDS Steam group

Steam id already in use....
Whats up everybody...I just recently tried to setup a CS:Source server and it seems to be up and running just fine, but whenever I try to connect to the server it gives me the "This Steam ID is already in use...". I have tried to connect to it with multiple accounts and they all get the same error. I have only tried connecting through LAN.

Also, I tried reading some other posts about this and read something about external and internal IPs. Didn't really understand what the difference is. The IP the console displays as the Network IP is the same as the IP I get from doing an ipconfig.

Thanks in advance.
Run ipconfig and use the one that coincides with "IP Address". Or is that the ip you were using?
Ya, that is the one I am using. Whenever I add the server it shows up fine, but it doesn't display it under the "Lan" tab.

I did just get it to work though when I changed sv_lan 0 to sv_lan 1...which I believe makes it only accessible through the lan and not internet. For some reason I do not get the "Steam id is already in use..." anymore.
Hmm, thats odd. When you change it to LAN only it's not VAC secure anymore so that might be why you don't get the Steam ID already in use msg. I know when I tried to connect to my server through the router ip it gave me that msg. To connect to mine I used the internal ip of the PC that the server was hosted on, but since you're getting that msg and trying to connect through the internal ip of ur machine, I'm kinda lost. Im sure skeletor or someone with a lil more knowledge then me will read this and set ya straight.
are you running the server on the same machine as you play on? and did you say that the server is running on the lan ip? which would be like 192.????. and you say it doesn't show up on your lan tab?

the difference between a lan ip and a external ip is that a lan ip is the computer internal network ip address, and an external ip address is the ip address the rest of the internet world sees your home network as.

what operating system are you running the server on? and do you have a router with the proper port forwarded? also, do you have the port open in the servers firewall?

Forum Jump:

Users browsing this thread: 1 Guest(s)