SRCDS Steam group

FPS is unstable

Over the past month I´ve tried everything... Except for using windows. The problem is that i can´t get fps any higher than 333.33. Once it´s up and running on 333.33 it becomes very unstable when actual gamers come and play ranging from 330 to 10 fps. I´ve have some graph´s on this on:

I´ve spend hours and hours reading up on this. Some claim rate settings need to be set and you can get as high as 1000FPS. But i´ve never seen it. Some claim that you need lots of CPU firepower, these are the systems i´ve been working with:

- P4 2400 Mhz, 1000MB mem
- P4 3000 Mgz (+ht), 1000MB mem
- 2 x Xeon 3000Mhz (+ht), 4000MB mem

Network is 100mbit to internet on all.

All these systems produce the same: 333.33 fps but very unstable. The graphs shown are actually from the dual xeon.

Some claim settings.... I like settings and i have patients :-) so i actually spend lots of time in server.cfg and my startup line. Mainly used info from I´ve tried tick 33, 66, 100. (tick 33 seems a bit better, but who wants a 33 tick server?) sv_maxupdaterate 33, 66, 100 and fps_max at 200, 300, 600, 1000 (almost every setting). Also tried various combo´s of traffic settings. Also tried pingboost... i don´t think there is such a setting of parameter with CS:Source as it does nothing.

Some claim Linux Kernel hz. This has proven to be an issue. It is now a standard option in the menuconfig, one might say that the problem is addressed. So again i´ve tried Debian stock kernel , SMP stock kernel (both 2.6.8-2-686-smp), Debian unstable kernel (2.6.14-2-686-smp), and compilled my own All kernels seem to run at 1000hz (I only compilled the last one meself so that one i´m sure off) It has not made a single fps more or less… Compiling it with many modules or with less, upwards or downwards… All the same results…

Sooo my question is: How to get this FPS thing stable and maybe somewhat higher (just to prove it´s possible maybe). I´m very willing to try your suggestions on the three boxes. I also have been wondering about contacting valve… How would one get in contact with them?



I think it is a linux issue period.i have this problem too

Forum Jump:

Users browsing this thread: 1 Guest(s)