SRCDS Steam group

SRCDS won't start - and I read the other posts!
Ok, first off, I can't thank you guys enough. I've lurked around for a long time and got a ton of useful info. Skeletor you deserve a job (or at least a paycheck) from Valve for your work here.

On to my issue:
I used to run a cstrike dedicated server with mani admin and CS:DeathMatch (using metamod). I went away for a month or so and come back to disaster. I have updated mani, updated meta, updated srcds and I get the same error seen in post: I gave up on GUI and went to command line (this is the text: C:\Games\Source>srcds.exe -console -game cstrike +map cs_office -maxplayers 24 +
fps_max 600) and get this (albeit quite an exercise with the pause key to catch this info):

Quote:Console initialized.
Attempted to create unknown entity type event_queue_saveload_proxy!
Game.dll loaded for "Counter-Strike: Source"
Loading Mani Admin Plugin 2005 V1.1.0zh,

Loaded playerinfomanager interface at 2244CC00
Loaded engine interface at 0DC55020
Loaded events manager interface at 0DCD7D68
Loaded filesystem interface at 100B6EF8
Loaded helpers interface at 0DE87934
Loaded networkstringtable interface at 0DE296B8
Loaded enginetrace interface
Loaded random stream interface at 0DC5301C
Loaded IServerGameEnts interface at 2243DE54
Loaded effects interface at 224333C4
Loaded sounds interface at 0DC552B4
Loaded cvar interface at 0DC4F510
Loaded servergamedll interface at 2243DE50
Loaded voiceserver interface at 0DE8C5C0
*********** Loading gametypes.txt ************
Searching for game type [Counter-Strike: Source]
Found gametypes for Counter-Strike: Source
Found advanced effects
Found voice control
Found kills offset
Found teams
Found team [#T]
Found team [#CT]
*********** gametypes.txt loaded ************

Nothing in there that alarms me, but after that, the console window closes and I've got nothing. Well, change that. I have a gorgeous collection of STEAM_***.MDMP files for each attempt. Each about 38k in size.

Please tell me I'm doing something stupid so I can quickly get around this. My next step is a complete refresh of my srcds install.

You step away for a little bit and all hell breaks loose. I can't wait to see what happens when I try and bring my Psychostats back up...

Thanks in advance for your help. You guys ROCK!
Besides Mani Admin, what other server plugins are you running? Are you using Server Checker or a .bat file? Does it just close or is it triggered by an event?
Mani Admin, Meta-mod and Counter-Strike Source Deathmatch are the three mods I run. The rest is just straight cs:s. No server checker (not sure what that is) and I took out the .bat file (I'm typing the above exec line at a cmd prompt). I failed to mention this is on an XP box above.
After it runs, there are no events in the windows event viewer, no messages that come up as errors and the console close is immediate. It pops up and disappears (unless I hit pause) in less than a second.

Thanks again for your help!
if i'm not wrong maxplayers must be defined by +maxplayers 24 not - Wink
ok, I'll give that a try (currently at work), thanks. But if I run it in GUI (where I only specify "game") the same problem persists. Any other possibilities?
first off thank you for your kind words Smile. i would love to be employed by valve, but I don't see that happening in the near future, lol.

but the first thing to try is to remove all of the plugins and try running a bare version of the server. if i remember right the cs deathmatch a lil while back after a valve update would crash the server, exactly the way yours is crashing. so take all the plugins off, run the server and see if it runs, if it does, add mani back on, and see if it runs. and then go from there, and whichever one kills the server, then its that plugins fault. and honestly the only plugin i really support as bieng stable is mani, and thats only if you have the most recent non-beta version. although i have heard the beta version is actually quite stable.

and also, it is -maxplayers.. atleast thats what i have in the cmd line for my servers Big Grin
Ok, I'm back up. I can't say I know the exact problem, but it had to do with Mani. Some config gone wrong. The patch I put on didn't seem too happy, so I went with a complete Mani install and then restored my specialized cfgs. Works like a charm. Thanks for the help skeletor! People like you make the net a great place Smile
lol well i do what i can =) and yea, if you had mani at one point in time, and just tried to update to the latest version, that probly wouldn't work, because he has put out a tons of updates, and if you miss 2 then you usually just have to do a full install. but glad its working Smile

Forum Jump:

Users browsing this thread: 1 Guest(s)