SRCDS Steam group

Core Dump when starting
Okay, I know I've seen this problem on other forums, but I just can't seem to get any of the other fixes to work that you have suggested. All of my info is listed below. I updated the source server a few weeks ago when the new terrorist model came out (guerilla) and it wasn't loading correctly (causing inconsitency error when someone tried to connect).

I couldn't get it to work so I wiped the entire game over and tried installing from scratch. Since then I either get no error message or this segmentation fault error. If I leave it to restart at least 4-5 times the server will sometimes actually stay up for many hours without a problem. Any help would be greatly appreciated.

./srcds_run -console -game cstrike -secure -port 27015 +map de_dust -tickrate 100 -debug -norestart
Auto detecting CPU
Using SSE2 Optimised binary.
Enabling debug mode

Console initialized.
Attempted to create unknown entity type event_queue_saveload_proxy!
Game.dll loaded for "Counter-Strike: Source"
maxplayers set to 32
Network: IP XXX.XXX.XXX.XXX, mode MP, dedicated Yes, ports 27015 SV / 27006 CL
Executing dedicated server config file
Summary:  339 resources total 14.29 Mb, 21.29 % of capacity
./srcds_run: line 426:  3758 Segmentation fault      (core dumped) $HL_CMD
cat: No such file or directory
email debug.log to
Fri Feb 10 20:20:56 EST 2006: Server Quit

CRASH: Fri Feb 10 20:20:56 EST 2006
Start Line: ./srcds_i686 -console -game cstrike -secure -port 27015 +map de_dust -tickrate 100 -debug -norestart
End of Source crash report


gcc --version
gcc (GCC) 3.4.5

ldd --version
ldd (GNU libc) 2.3.2

uname -v
#1 SMP Wed Sep 7 13:28:55 EDT 2005

uname -a
Linux XXXX.XXXX.XXXX.XXXX 2.4.21-37.ELsmp #1 SMP Wed Sep 7 13:28:55 EDT 2005 i686 i686 i386 GNU/Linux

Dell Poweredge Server, 2U
2x HT-capable 2.8GhZ Intel Xeon Pentiums
Quote:In short, a segmentation fault occurs when a program attempts to access a memory location that it is not allowed to access, or attempts to access a memory location in a way that is not allowed (e.g., attempts to write a read-only location, or to overwrite part of the operating system).

Is your server dir chmod'em for write access? (does your user have rights to write in server dir)

If i remember correctly i fixed this error by moving server to another dir.

This is just a lucky guess so sorry if i'm wrong Smile

Forum Jump:

Users browsing this thread: 1 Guest(s)