SRCDS Steam group


No one can connect to my server with my external IP.
#1
I wanted to make a gmod server because my fav server went down.

I installed srcds and gmod and some plugins for admin but when i stat it no one can join using my external IP.

Here is the code for the run bat file.

Code:
@echo off
cd C:\SRCDS\Servers\orangebox\
echo Starting game server.
echo Starting FancyPants Bhop
C:\SRCDS\Servers\orangebox\srcds.exe -console -game garrysmod +gamemode terrortown +map gm_flatgrass +maxplayers 10 +hostport 27016 -clientport 27005 -tickrate 32
echo Server has now started.

Everything runs fine when i connect with 192.168.2.104(My static IP)
But my external ip just won't work. (Connection failed after 4 retries)

Please help?
Reply
#2
I believe you mean internal IP, not static. But nevertheless, the most obvious question, did you forward the port that you are going to use? I would suggest removing the +hostport and -clientport options and adding a single -port with the port you're using. That is the port that you should forward both UDP and TCP.
Reply
#3
(04-08-2013, 10:06 AM)beelze Wrote:  I wanted to make a gmod server because my fav server went down.

I installed srcds and gmod and some plugins for admin but when i stat it no one can join using my external IP.

Here is the code for the run bat file.

Code:
@echo off
cd C:\SRCDS\Servers\orangebox\
echo Starting game server.
echo Starting FancyPants Bhop
C:\SRCDS\Servers\orangebox\srcds.exe -console -game garrysmod +gamemode terrortown +map gm_flatgrass +maxplayers 10 +hostport 27016 -clientport 27005 -tickrate 32
echo Server has now started.

Everything runs fine when i connect with 192.168.2.104(My static IP)
But my external ip just won't work. (Connection failed after 4 retries)

Please help?

Hey there, beelze!

This issue are the most often ones. This issue is the portforwarding, the bat file or the config file there are guilty in that error/fail you are expecting. If you absolutely will have a bat file, just use this one, clean and simpel:

@echo off
cd c:\srcds/orangebox
echo Starting gameserver..
C:\SRCDS\Servers\orangebox\srcds.exe -console -game garrysmod +gamemode terrortown +map gm_flatgrass +maxplayers 15 +port 27015
echo Your gameserver is now up and running!

Then you will need to check your config file dosen't say the Server is only LAN. You know:
"sv_lan" "0"

Then you will also need to check your portforwarding:
TCP/UDP: 27015
Then goto: http://www.canyouseeme.org/ and check about it can see your port. If the website can see your port then take the public IP it shows and put the port after the IP, like this:
xxx.xxx.xxx.xxx:27015 and connect your Server on that IP, also called your Public IP. If the website can't see your port then make a new post on this website or contact me on:

Steam: bilbodog
Skype: bilbodog2
Email: casperpvp@gmail.com
Facebook: https://www.facebook.com/bilbodog2

- Best Regards bilbodog (Casper Thomsen)
For more help, just hit me:
Steam: bilbodog
Skype: bilbodog2
Facebook: http://www.facebook.com/bilbodog2

And don't forget to +rep [Image: NET-5.png]
- Best Regards bilbodog (Casper Thomsen)
Reply
#4
Hi, I wasn't able to make my server public neither because I checked if the port 27015 was open from http://www.yougetsignal.com/tools/open-ports/ (when having the server on) and it was closed. I was very stuck because I had done the other steps well, and opened 2715 TCP & UDP.
Strangely, by setting more ports, which on http://portforward.com/ I found that were needed for HL2 Servers, I got my server online and I saw opened the port 27015 from the website.

So, if you think you haven't done anything wrong, as I thought, try opening these ports:

27014-27050 TCP
4380 UDP
27000-27030 UDP


Some more "strange" things, are that I can't connect to my server using my public IP, only with my internal ip, but others can do, same as it's appearing on the server list (with public ip) only for them. Also, I didn't even see my server on gametracker.com

I hope it solves your problem, too Smile
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)