SRCDS Steam group

srcds installed but how do i run?
ok you'll have to bear with me as I am a linux noob!

Right we have a dedicated server sitting somewhere so that we can run our CS:S server on it. Access is via SSH obviously (which i have never used before) and i have never, ever used linux before. I think the server is running linux fedora core or something.

So all of the installation files and everything are on the server but we have no clue on how to run the files to start the server up!!!!

I've tried "./srcds_run -console -game cstrike -tickrate 66 etc, etc" but all I get back is "no such file or directory"

BUT IT IS THERE!!! I can see it!!! but how the hell do i run it! I've been trying for hours! Read loads of forums n guides and tutorials but nothing works!

If someone would be kind enough to help me out and explain if I'm doing anything wrong I would greatly appreciate it!

Thanks a lot

Make sure you're in your Steam directory when you try the "./srcds" command.

If you're in the wrong directory and try typing the command, you'll always get "no such file or directory".

If you're unsure where the srcds file is, type "find / -name srcds_run" and it should come back with its location, if it exists. If you think you're already in the Steam directory, type "ls" and it should list all the files in the current directory.
yeah I'm definetely in there! I've now got it to say "invalid game "cstrike" specified"

I was wondering whether this was something to do with like the server not being logged onto steam or something but we've been trying for ages!


Try ./steam -command update -game "Counter-strike source" -dir .

It sounds like it might not installed in the right directory/in that directory at all o.O

Forum Jump:

Users browsing this thread: 1 Guest(s)