SRCDS Steam group

Server having problems sending to clients
Hi all,

gcc (GCC) 3.4.2 20041017 (Red Hat 3.4.2-6.fc3)
ldd (GNU libc) 2.3.3
2.6.9-1.667 #1 Tue Nov 2 14:41:25 EST 2004 i686 athlon i386 GNU/Linux

AMD Athlon XP 3200+
nForce2 Ultra 400
10Mbit connection
Fast download redirection enabled from my webserver, not being pulled from the gameserver

I am running into a problem on my 66tick 16 player server. When looking at the netgraph_3 , the server appears to send information fine to the clients as it is a constant 50-66 in.

The clients however will drop to 24-35 out when the server gets about 12 players on it when looking at the net_graph 3 in-game.

Here is the important part of the server.cfg

sv_allowdownload 1
sv_maxupdaterate 66
sv_minupdaterate 10
sv_maxrate 20000
sv_minrate 6000

I am not sure how to resolve this problem, as the MRTG graphs show very little line utilization, and CPU utilizationi on the server is at about 29% when the server is full:

CPU In Out Uptime Users FPS Players
27.00 48849.81 76104.65 342 7 333.56 15

I have allowuploads disabled. I have allowdownloads enabled, but all the custom content is pulled from my website, not the server. I have tried a number of things to try and resolve this problem.

Is this a CPU limitation on the server? I have also noticed that I cannot get the server to run above 333 FPS. Might this be an issue?

I have the option to upgrade to a Athlon 64 3700+, but I really don't think this is a CPU problem.

Any help or suggestions would be appreciate.d. Here are my server start parameters:

echo "Starting Cs:Source Server"
sleep 3
screen -A -m -d -S css-server ./srcds_run -console -game cstrike +ip -port 27020 +map de_dust2 +maxplayers 16 -autoupdate -tickrate 66 +fps_max 600 +exec server2.cfg
Server Admin-24/7 Absolute[K]arnage DUST
Absolute[K]arnage CAL Match server

Site admin-

Forum Jump:

Users browsing this thread: 1 Guest(s)