SRCDS Steam group

Update refuses to put the installation in the correct directory
I'm running SRCDS in Linux (Debian), but it seems to be more of a general issue than a Linux issue.

I have a (couple months old) install of Left 4 Dead 2 I wanted to update in the directory /home/hlds/.games/left4dead2/. This is the command I'm running:
./steam -command update -game "left4dead2" -dir /home/hlds/.games

But when I try to update, it constantly tries to create a /home/hlds/.games/left4dead2/left4dead2 directory and install everything there. so I tried moving the "/home/hlds/.games/left4dead2/" directory to "/home/hlds/.games/left4dead2/left4dead2" and running the same command. But now, it actually tries installing to the correct directory of "/home/hlds/.games/left4dead2".

What is going on here? I can't seem to figure this out.
Have you tried clearing the .blob files?
This seems kinda odd...
~ Mooga ...w00t? - on Twitter
[Image: 76561197965445574.png]
Please do not PM me for server related help
fqdn Wrote:if you've seen the any of the matrix movies, a game server is not all that different. it runs a version of the game that handles the entire world for each client connected. that's the 2 sentence explanation.

Forum Jump:

Users browsing this thread: 1 Guest(s)