SRCDS Steam group

Illegal Termination of Worker Thread, What does this mean?
My srcds no longer loads maps in synergy no more due to this error. I re-installed srcds for synergy, and it did not fix. The srcds.exe crashed after attempting to continue to load a map when I was in Episode 1 Co-op. I have the games mounted etc... but this crash just comes out of no where then the whole srcds program for synergy is shot to hell. It only showed that error message once then now I cannot attempt to load a map again. When I do srcds just closes showing no error messages and leaves me with an error crash log file.
The map it tried to load but crashed on is ep1_citadel_02b
Highly doubt the map would matter though
My srcds for TF2 servers is working fine though.

Do not ask me about my computer stats or internet connectivity, I have well above average stats for both to handle this program, and ports perfectly in range.

So also what does this even mean. Why is srcds making illegal terminations? Is it retarded?

And what the hell is a worker thread?

Any help with this problem is appreciated.
Sometimes srcds gets this and starts right back up no problem but something must of gotten really f**ked up to cause it to do this crap.

~Installation info and srcds command line~

Hldsupdatetool.exe -command update -game synergy -dir c:\Synergy
C:\Synergy\orangebox\srcds.exe -console -game synergy -maxplayers 10 -port 27015

Nothing has changed srcds but this crash so I highly doubt this info would matter either.
let me guess. your getting this error correct?

threadtools.cpp (2610) : Assertion Failed: Illegal termination of worker thread
'CNet Encrypt:0'
Assert( Assertion Failed: Illegal termination of worker thread 'CNet Encrypt:0'

or something similar to it ?

if so, do you have any mods for your sever? mani? sourcemod? i had this error for my tf2 server and it basicly crashed it every time i joined. I think it was mainly because of all the mods i had.... but any how have you tried to update your server with -verify_all at the end? Hldsupdatetool.exe -command update -game synergy -dir c:\Synergy -verify_all you could trie that i guess and if you have any mods on there i would sugest removing them imedently.
Yeah I got an error similar like that. I tried what you said to do, it had no effect. I don't use any mods for Synergy but for my TF2 srcds I have it spammed with mods and working.

The only thing close to a mod or if you would consider it one for Synergy is a small server.cfg which executes on each map load and adjusts weapon ammo and damage. I don't think it causes the crash though. If you really need to see it go ahead. And thanks for the reply. I barely get any help on srcds forums but its worth to try it. Nothing else to do and I tried doing research and got no where from fixing this problem.

sk_max_pistol 300
sk_max_357 100
sk_max_smg1 1000
sk_max_smg1_grenade 5
sk_max_ar2 800
sk_max_ar2_altfire 5
sk_max_buckshot 200
sk_plr_num_shotgun_pellets 12
sk_max_crossbow 100
sk_max_grenade 25
sk_max_rpg_round 10
sk_plr_dmg_pistol 8
sk_plr_dmg_ar2 12
sk_plr_dmg_buckshot 10
sk_plr_dmg_grenade 125
sk_plr_dmg_rpg_round 150
sk_plr_dmg_smg1 6
sk_plr_dmg_smg1_grenade 125
sk_plr_dmg_357 100
sk_plr_dmg_crossbow 300
sk_plr_dmg_crowbar 20
got this error alot too -.-
I use serverdoc and it doesn't crash the srcds.exe just shuts the server down without exiting srcds.exe
GFL(Games For Life) Founder.
Private Message me if you need any help!
Recommend everybody uses NFO
My Group: GFL
[Image: b_560_95_1.png]
[Image: b_560_95_1.png]

Forum Jump:

Users browsing this thread: 1 Guest(s)