SRCDS Steam group

Newb help (port problem)
First off, I appologize if this topic is covered, but I searched and found nothing.

I am just starting to run a CS:S server, I managed to get it up and running and what not. Now I have a network, I have the server running srcds and my second box is my game machine. Now I have forwarded all the necessary ports and what not to the server, and even have the -port 27015 tag in the cmd line. (The full cmd line is: D:\SRCDS\srcds.exe -console -game cstrike -port 27015 +maxplayers 12 +map de_dust2 +exec server.cfg)

Now the server loads great, even shows up in the steam server list. I can connect to it off of my network, but seemingly no one else can, and I think the reason is this... When I see the server in the steam server list, check out the info... this shows up: IP 70.*.*.*:63748 is [GCB] Apoth's Test Server.

thats right... port 63748?

I have a feeling if I can get it to not be on that port I can get it working properly. Any ideas?

Thanks in advance!

***EDIT*** - I forgot, as a side note, Ive got it added to my faves via the lan address ( and it shows up as port 27015 there. Dont know if that will make a difference, but it might so here it is.
yeaaa.. you have a d-link router don't you....

if you do, i have heard that you can fix this problem by downgrading the firmware.
Thanks for the tip!

Unfortunately, still in the same predicament. My network sees it on port 27015, and the internet now sees the server on 60043. I also noticed that when people are trying to connect to the server, it says bad or old challenge from X.X.X.X.

Has anyone ever come across this before, and is it truly my router? I don't mind switching to a new one, but if anyone has a D-Link (or anything) and managed to overcome this problem, advice would be greatly appreciated!


EDIT - As a side note, I have googled till my hearts content, but the oldest firmware I can find for my DI-604 Rev E is 3.01. Now that didnt work and reading through posts some people have managed to get it working with 2.x versions. Anyone know a good resource or happen to have one kicking around?
well i can't help you very much on the firmare.. im a linksys user myself. but yes, it is truely your router. i mean really. what else would change the port? and d-links have been known to do this before.
Lemme guess... Your running your srcds on a Verizon FIOS connection behind the VZ provided D-Link router?

Had the same problem until we replaced the D-Link with a Linksys WRT54G... Problem is, you need an older model. Check out the following Autopsy: Linksys WRT54G/GS Hardware Versions Under the Knife page. You need to find one with the serial numbers CDF5xxx thru CDFAxxx (which can be ugly; I searched thru dozens of them at BestBuy, CC, Staples, OM, etc. until I found an older one at a Walmart). Something to do with these routers having a 10/100 WAN interface vs. a 10 mbit WAN. The 10 mbit routers can't handle the 15 MB down. I believe that Linksys has also come out with a WRT54GL that is a new release of the older, more configurable models. Search around for the reasons to stay away from the CDFBxxx devices (other than having half the memory as the others). The site is a good resource for info, especially the forums...

Thanks for all your help guys.

Now if its the router, I might as well just haul off and get a new one... any suggestions as to what works well/doesnt?

And to answer you, no, Im running A DI-604 through Rogers (canada) Extreme Speed (5Mbit) connection. I wish I could get fios, I used to do tech support for it.

But ya, if anyone has any ideas what is a good router that will work for this, and is moderately priced input is appreciated!
well if you don't want wireless or anything... i use a linksys befsr41, and i haven't had any problems.. and for wireless.. i also have linksys... but i don't know the model, that router is upstairs.. lol. and i haven't had any problems with any of them, and there used quite a lot.
i just got that problem with my DI-604revE, but its now corrected, i made 2 changes, and it started to work properly. just try for urself which will help you

1 change: added "-tickrate 66" in starting lane
2 change: downgraded firmwave of my di-604revE router to 3.36

i hope it will help you

the tickrate has nothing to do with the router changing the port... lol. but downgrading is the answer, and i think d-link has that version on there site. soo you should try it apoth... its cheaper then a new router, lol
Well, thanks for the help guys but it looks like its not going to work. I just downgraded firmware and set it all back up, even tried a DMZ for the final time but to no avail. Looks like ima head off to buy a new one.

Thanks for all the input guys!
Just an update for yall...

Went and bought a new linksys router, set it up, and the server is working beautifully.

Now just to read up on how to get it tweaked!
Thanks again all!
lol yea.. i have always used linksys, and they have never let me down! and i use it pretty heavily, streaming music and video and such, along with runnin a domain controller. but glad its all working for ya! Smile
I had the same problem with my DI-604 rev E (setting port 27015 but getting 62695), I went here to look how, I read this whole thread then I went to downgrade my firmware like u said but before doing that, I went in my Router Settings and in The "Tools" Tablets, You select "Mics"" and if u scroll down, there is an option called WAN -WAN select to 10/100 Mbps
100Mbps/Full 10Mbps/Full 10/100Mbps Auto- , mine was at 10 Mbps and I just tried to set it at 10/100Mbps auto, I didnt know the consequences but now when I open my Source Dedicated Server, its always set on the 27015 port, keep that in mind and try it if it works, cause it did for me, funny huh? Smile
hmm.. ill have to keep that in mind for future reference if anyone else comes with that problem!
Im not having a problem with the port, rather then getting the start of my IP to switch from 192.x.x.x?

Forum Jump:

Users browsing this thread: 1 Guest(s)