SRCDS Steam group

Failed to load Steam Service
Hi friends!

When I started the server by ./srcds_run command, the follow error is shown at output console:

Initializing Steam libraries for secure Internet server
Failed to load Steam Service
ServiceStart: failed to start
Looking up breakpad interfaces from steamclient

Even with this error, the server it´s working.

Does anybody know what the reason of this error and how to solve it?


Luis Carlos
Ignore it, it's not causing any damage and it is not affecting anything.

Thanks for your help!!!

Luis Carlos (Brazil)
Hi i have the same error except on windows dont know whats causing it my server was working fine then an update came out now i get the same error and my server is not appearing on the server master list can anyone help im stumped on how to fix this

Your server is in Linux or Windows? If Linux, try to check the firewall IPTABLES.


Luis Carlos (Brazil)
Skype: lcb.lucas
sorry i have posted in linux but its the same problem i have accept im using the windows srcds version. All my ports are fowarded correctly and the server ran just fine until the gift grab update since then i have the steam service failed to load error. My servver appears in the LAN tab on find servers but not on the internet tab or my favourites tab. I have tried disableing my firewall yet i still have the same problem.

Did you checked the firewall between Internet and your LAN?

Luis Carlos
Skype: lcb.lucas
i have a feeling that the problem is that my isp has blocked the ports because i have checked all my ports, checked all my fiewall settings and everything is normal and the server should run the only thing i can think of is that my isp has blocked the ports

(isp internet service provider)

I know that they block any ports, like 80 (http) and 21 (ftp). But the Counter Strike ports I think that no.

Where are u from?


Luis Carlos
Skype: lcb.lucas
(01-04-2012, 03:07 AM)luedfe Wrote:  Evil,

I know that they block any ports, like 80 (http) and 21 (ftp). But the Counter Strike ports I think that no.

Where are u from?

i am from the uk and all my ports i need are fowarded

these are the ports

1200-1200 tcp

3478-3478 udp

4379-4378 udp

27000-27050 udp

i have tried 27015-27015 tcp/udp and still no joy
i tried turning all my fire walls off and running the server but still that did not work. i dont think it is my isp blocking the ports because i can play steam games online.

sorry for the late reply hope you can help
It's not a problem, and you cant fix it.
(05-02-2012, 10:54 PM)Mike Wrote:  It's not a problem, and you cant fix it.

how cant it be fixed may i ask and what causes it do u know ?

it is a bit of a problem as my server does not show on the internet tab in css server browser and when i try to join via my external ip it says connection failed after 4 retries, friends cant join either but what is strange is that i can join my server via the lan tab the server cfg looks like this
all letter x in the server.cfg are there to cover up my ips and passwords : )
// server name
hostname ".:C.O.G:. private server "

// rcon passsword
rcon_password "xxxxxxxxxx"

// Server password
sv_password "xxxxxxxxxxx"

// server cvars
mp_friendlyfire 0
mp_footsteps 1
mp_autoteambalance 1
mp_autokick 0
mp_flashlight 1
mp_tkpunish 1
mp_forcecamera 1
sv_alltalk 0
sv_pausable 0
sv_cheats 0
sv_consistency 1
sv_allowupload 1
sv_allowdownload 1
sv_maxspeed 320
mp_limitteams 4
mp_hostagepenalty 5
sv_voiceenable 1
mp_allowspectators 1
mp_timelimit 25
mp_chattime 10
sv_timeout 65

// round specific cvars
mp_freezetime 6
mp_roundtime 5
mp_startmoney 800
mp_c4timer 45
mp_fraglimit 0
mp_maxrounds 0
mp_winlimit 0
mp_playerid 0
mp_spawnprotectiontime 5

// bandwidth rates/settings
sv_minrate 0
sv_maxrate 0
decalfrequency 10
sv_maxupdaterate 60
sv_minupdaterate 10

// server logging
log off
sv_logbans 0
sv_logecho 1
sv_logfile 1
sv_log_onefile 0

// bots
bot_quota 5
bot_quota_mode fill
bot_difficulty 1
bot_chatter off
bot_auto_follow 0
bot_auto_vacate 1
bot_join_after_player 1
bot_defer_to_human 1
bot_prefix ".:C.O.G:."
bot_allow_rogues 0
bot_walk 0
bot_join_team any
bot_eco_limit 2000
bot_allow_grenades 0
bot_allow_grenades 0
bot_allow_pistols 1
bot_allow_sub_machine_guns 0
bot_allow_shotguns 0
bot_allow_rifles 1
bot_allow_snipers 0
bot_allow_machine_guns 0

// operation
sv_lan 0
sv_region 3

// execute ban files
exec banned_user.cfg
exec banned_ip.cfg

ip 192.168.1.x
hostport 27015
Take the ip and hostport out of your config and command line.

Make sure you are port forwarded if behind a router.
tried doing what you advised and still the server wont appear in the master server list


Forum Jump:

Users browsing this thread: 1 Guest(s)