SRCDS Steam group

[L4D2] Session is no longer available problem
Big Grin 
Hello, I installed a L4D2 server for me and my friend to play on with plugins from SourceMod. I was testing and all the times I kept testing I got "Disconnected- The game is no longer available" I got the server to work once, only out of sheer luck.(i had to exit out of it because my plugins weren't working for SourceMod, now they are)

At first I was missing the server.cfg file, then I got it and added it, still doesn't work. The console says my server is dedicated and is working, but something is preventing me from connecting to the server.(Ports and everything are forwarded.)

anyone curious, here's my server.cfg
/ L4D2 Server Settings!
// Test

hostname "Left 4 Test 2"

// == Rcon Settings =
rcon_password "pass"

// Steam group that this server belongs too.
// You can find your group's id on the admin page of the group.
sv_steamgroup 2030589

// Difficulty Setting: easy, normal, hard, impossible
z_difficulty normal

// this will allows you to find a server through matchmaking with a specific search string
sv_search_key test

// The resion of the world to report this server is.
// Region Codes: 0 - US East coast, 1 - US West coast, 2 - South America, 3 - Europe, 4 - Asia, 5 - Australia, 6 - Middle East, 7 - Africa, 255 - world
sv_region 255

// Contact email for server sysop

// Players can hear all other players' voice communication, no team restrictions
sv_alltalk 0

// keep pausable off since it can interrupt gameplay.
sv_pausable 0
sv_voiceenable 1
sv_consistency 1
sv_allow_wait_command 0


// Allowed Gamemodes
// What the server is forced to play, blank allows all. (versus,survival,coop) comma separated values.
sv_gametypes "coop,versus,realism,teamversus"

// The one the server runs...
// OLD! Set via cmd line...
// mp_gamemode "versus"

// start execute ban files

exec banned_user.cfg
exec banned_ip.cfg

// Server password
//sv_password "test"

// Server Cvars
mp_disable_autokick 1 //Prevents a userid from being auto-kicked
sv_allow_color_correction 1 //Allow or disallow clients to use color correction on this server.
sv_allow_wait_command 1 //Allow or disallow the wait command on clients connected to this server.
sv_alltalk 1 //Players can hear all other players, no team restrictions
sv_alternateticks 0 //If set, server only simulates entities on even numbered ticks.
sv_cheats 1 //Allow cheats on server
sv_clearhinthistory 0 //Clear memory of server side hints displayed to the player.
sv_consistency 1 //Whether the server enforces file consistency for critical files
//sv_downloadurl “” //Location from which clients can download missing files

// Server Logging
log on
sv_rcon_log "1"
sv_logsdir "logs"
sv_log_onefile 0 //Log server information to only one file.
sv_logbans 1 //Log server bans in the server logs.
sv_logecho 0 //Echo log information to the console.
sv_logfile 1 //Log server information in the log file.
sv_logflush 0 //Flush the log file to disk on each write (slow).
sv_logsdir “logs” //Folder in the game directory where server logs will be stored.

//Server Rates
sv_maxcmdrate 100 //(If sv_mincmdrate is > 0), this sets the maximum value for cl_cmdrate.
sv_maxupdaterate 100 // Sets the maximum value for cl_updaterate
sv_minrate 25000
sv_maxrate 50000
sv_unlag 1
sv_maxunlag .5

//Fix to get your server onto the master lists (unknown if you really need this)
setmaster add
setmaster add

//Set to 1 to only allow members of the steam group to make the initial connection to this server
sv_steamgroup_exclusive 0

//Allow connections without creating lobby. Set to 1 to allow lobby connections only
sv_allow_lobby_connect_only 0

Server OS: Windows 7 32-Bit
Processor: AMD Athlon™ 64 X2 Dual Core Processor 4400+ 2.30GHz
Ram: 2.00GB
Game(s): Left 4 Dead 2
Start Up Command: -console -game left4dead2 -maxplayers 2 -autoupdate -nohltv -secure -maxclients 2 +sv_lan 0 +map l4d2_wanli01
Admin Mods: SourceMod & MetaMod

Alright, I got it working(for me atleast, by setting sv_allow_lobby_connect_only 1 to 0) my friend just said he cant find my game, and when I join, the option to invite is grayed out.
Is the server running on the same computer you are playing on? Are you connecting to your server using your local ip address?

if you intend to use sv_search_key do not set (sv_steamgroup and/or sv_steamgroup_exclusive)

go to Options -> Multiplayer -> Automatically Discover LAN Games -> Disabled

type status in server console, copy the PublicIP and port (you can get the ip in other regular ways, but this way can see if it has problem connecting to Steam or other problem)

then in game client console mm_dedicated_force_servers PublicIP:Port
(you can paste this command at launch options, and rcon_password *** too, add a + at the beginning of the command)

when create lobby, it will force to connect your server (if server status says it's reserved, wait 2 minute and try again)

game play only uses UDP, if you want to remote into the server, need port forward TCP too.
if you can remote into and kick anything, it's working
rcon kick bill
I'm having this problem too , in my problem when my server loaded finale map and start executing finale script it will .... well activate total server lockdown . Player will play through finale map and move to the next campaign then you can join the server normal .
If server reach this condition it will realease the lock.
#1 : All players must finish the finale map and change new campaign
#2 : All players died and still free slot in the server
#3 : All players left the server and it will execute reset campaign.

Forum Jump:

Users browsing this thread: 1 Guest(s)