SRCDS Steam group

Tf2 Missing Maps/Map differs from server
Before you all say "do this do that" lemme tell you what I've done, and my theory.

I have a few maps that range from 80 MB to 130 MB I'm trying to put on my server. The problem is, everyone gets an error.

In my config I have sv_allowdownload set to 1, and sv_allowupload set to 1, net_maxfilesize on 64 (that's the limit according to TF2), and my sv_downloadurl is set.

Now, the thing I don't get is, any file under 64 MB will download. Even Bz2 files. So basically, if I have all the maps on the FastDL as bz2 files, the ones under 64 MB will download. Once they extract though, I get a map differs from server error.

I have tried a 62 MB map, and it's worked fine, but a 65 MB map didn't work. I know sv_downloadurl is supposed to override the net_maxfilesize limit, but it doesn't seem to be doing it here.

It seems like it's not overriding the net_maxfilesize limit. The thing is, since Source limits downloads directly from the server to 20kb/s, and I got MARIO_KART (35 MB) in a minute from the server, fastdl has to be working.

I've tried 2 different fastdl hosts, and neither work.

Also, I can connect to the fastdl server through my web browser.

Can anyone help me? Is there way way to override the 64 MB limit?

Forum Jump:

Users browsing this thread: 1 Guest(s)