SRCDS Steam group

Apparent Infinite loop when executing 'steam'
I'm using a Ubuntu Server OS on the Oracle Virtual Machine.

After going through these steps:

It's become apparent that the virtual machine enters some kind of loop it can't break out of when I do './steam' to update it OR when I run './srcds_run'.

When I use sudo it works fine, though the CSS server I installed asks me not to run it as root (and I definitely do not want to) but I shouldn't need to use the sudo command so there's definitely something amiss.

Terminal snapshot, sudo ./steam (working fine):
sam@ubuntuserver:/home/steam/srcds_l$ sudo ./steam
[sudo] password for sam:
Checking bootstrapper version ...

Use: steam -command <command> [parameters] [flags]


update: Install or update HLDS

      -game <game>            -   Game name (use '-command list' to see available games)
      -dir <installdir>       -   HLDS Install dir
      (if dir not specified, will use value from last run of tool)

      -verify_all             -   Verify all HLDS files are up to date
      -retry                  -   Automatically retry every 30 seconds if the Steam Network is busy
      -remember_password      -   Remember password (if a username is supplied)

   For example: steam -command update -game cstrike -dir /hlds

version: View installed versions

list: View available games

Optional parameters for all commands:

      -username <username>    -   Steam account username (only needed to access limited content)
      -password <password>    -   Steam account password (only needed to access limited content)

CAsyncIOManager: 0 threads terminating.  0 reads, 0 writes, 0 deferrals.
CAsyncIOManager: 8 single object sleeps, 0 multi object sleeps
CAsyncIOManager: 0 single object alertable sleeps, 0 multi object alertable sleeps

Not using sudo
sam@ubuntuserver:/home/steam/srcds_l$ ./steam
Checking bootstrapper version ...
removing stale semaphore last operated on by process 1417 with name 0eBlobRegistryMutex_A7CD3883333D1020A7C035F1967908A1
removing stale semaphore last operated on by process 1417 with name 0eBlobRegistrySignal_A7CD3883333D1020A7C035F1967908A1

The terminal will stay like this until I cancel it.
My network monitors show nothing so it's not waiting for a download to complete.
The same also happens when running './srcds_run', it works when using sudo but hangs when I run it normally (hanging on the same line).

The process also takes all the CPU it can get, as shown by top:
1432 sam       20   0  5272 2188 1396 R 97.7  0.1  26:54.59 steam

Anyone got a clue?
On a separate Orcale VM I'm getting even stranger hangs on the download (Says something to do with it's checking base sound and hangs). For now until I get a linux box I'm putting it down the the VM
probably the mistake was to run steam as root via sudo once. make sure all files are owned and writeable by the casual user, also check the .steam directory in the users home directory. sudo often does not correctly set $HOME, so steam might have written into the casual users home directory even when running is as root...

btw: running game servers in a VM is not a good idea and will most certainly not result in an acceptable quality. (Linux Kernel HOWTO!)
Do not ask technical questions via PM!
I'm running the server as a VM for testing and writing scripts, not for actual use. I just don't have access to a server yet Smile

And I didn't run it as sudo first, the only things I had to sudo was chmod and chown when I created the /home/steam directory

The directory was not in MY home directory, I created /home/steam, did 'sudo chown sam /home/steam'
and then installed everything in there.

I only executed anything as sudo AFTER it failed normally

Forum Jump:

Users browsing this thread: 1 Guest(s)