SRCDS Steam group

srcds not starting
Hi I have just updated my srcds. When I try and start the server now the cmd window pops up for a second then just disappears. Any Ideas.


are you runnin gui version, console version? stand alone, or through steam, any plugins installed on the server. if your using console whats the start up line? id be happy to help, but i think imma need just a lil more then that =P
he's say's he uses srcds so i guess he uses the stand alone version, but some more info could be usefull yes.
game, plugins, ext.
Hi And thanks for the reply. I am using the stand alone. The command I am using is,
f:\srcds\srcds.exe -console -game cstrike +map fy_iceworld_orig -maxplayers 8 -autoupdate

If you need any more info let me know. Was working up until I needed to do an update. Had not used it for a while decided to use it with some friends last night and told me it ws out of date and to update and restart. I have doen the update now dead. It is a bit of a pain as my
dedicated server through steam wont work for CS:s either. Good old valve. It is normally CS:source I use on the server and have the mani admin plugin. The steam dedicated server is working for other games. Thanks again for the help guys.

alright, well if you haven't used it in awhile, then you probly have the old version of mani. jump over to there site and get the latest version, i wouldn't get the beta quite yet, but like version zg or some nonsense like that. a update a couple weeks ago broke mani. get back here if that doesn't work. but anymore, valve loves to break mani lol. every other update does. but theres talk on the hlds list that valve may add mani into there things to test with the server before releasing updates. atleast if i understood what alfred said right. lol.
Thanks that seesm to have got it up and running again just need to do some fine tuning now. Get it running nice and smooth. Still ahve no idea what is wrong with the steam version. Some crap about needing to repair the cache. never mind one working will do.

I have the same trouble with srcds.exe.

Yesterday i downloaded and upgraded with hl2upgradetool the Day of Defeat: S server.

I only have installed on machine the srcds and the hl2upgradeutility.

The upgrade process worked fine without issues or any kind of problem.

When i start the server with the following line:

srcds.exe -console -game dods +map dod_flash -maxplayers 16 -autoupdate

the msdos shell accept the command beacause no error is shown on screen, but the server isn´t start. Nothing occurs.

I followed the tutorial of this page step by step... im lost.

I created a server.cfg file and i placed it on cfg subfolder of the dod folder on the current directory (c:\srcds\dod\cfg\server.cfg, i take a sample file of other post.)

I tried to launch the server from Valve UI Source Dedicated Server. It works fine but i can´t play when my server is running even if i use a friend´s login account.

Anybody can help me?

Thanks in advance


if i run srcds without parameters, nothing occurs too. :S
I have a w2003 server machine with 512 ram and amdk7 proccesor. No sound and graphic card driver are installed on the server machine, because i think is optional...

Thanks in advance again.

pisbur Wrote:srcds.exe -console -game dods +map dod_flash -maxplayers 16 -autoupdate

the game should be just dod. since its a source dedicated server, the source part of that is a givin =). also -autoupdate is now a valid windows flag, thats only linux it works, or atleast i heard it works on linux (would be nice though if it workd for windows as well...).

/edit-im pretty sure about the whole dod thing.. never ran a dod:s server, and i never can remember what people say. my memory's goin to hell lol.
Hi, OK now have got everything running quite well. Want I want to do now is have the ability to have 2 start up commands. 1 for a normal mani sever and 1 for a mani ZOMBIE server. Does not need to be used to gether. Had a go my self but can only get the zombie server up and am too lazie to copy the whole lot and just have 2 srcds folders.

Thanks again

actually right now im not sure if there is a way to do that.. cuz you could have it load 2 different configs, thats easy, but i don't know hot to make it not load a plugin. i might have an idea, but right now i don't have time to check it out. a lil later ill look into it, and get back here if i figure something out, or not..

..unless thers a cvar to completly disable the zombie plugin, you could put that in the config that you don't want it to load.. but i don't know about the plugin itself..
No problem will check back later and do some hunting my self

Thnaks again skeletor


alright.. i really have no idea if this will work... but in the start up line of the server you don't want to load the zombie plugin, add like -plugin_unload "plugin name" (i have no idea what you would put in for the zombie plugin. lol) but yea.. worth a shot.

other then that though you can add -servercfgfile server1.cfg to the start line, and then the other one -servercfgfile server2.cfg
/note that im pretty sure you can not have a server.cfg file present at all if you do that. but then each server will have a totally different config.
I have the same problem. I downloaded CSS Dedicated server today and I cant run srcds.exe. When I F:\Srcds\srcds.exe -console -game cstrike +map de_dust -maxplayers 16 -autoupdate nothing pops up. And same thing happens when i try to start the srcds.exe (GUI). I am not using any plugins or mods. This is orig stand alone server. Thanks for your help.
well with windows you don't need -autoupdate.. it doesn't do anything. but hmm.. try re-running the updatetool? that should work.
Heh thanx. Tried with no -autoupdate and it works... Thanks a lot. But GUI still does not work.

Forum Jump:

Users browsing this thread: 1 Guest(s)