SRCDS Steam group

Srcds Broken Update
I've been reading around, and have come to the conclusion that the server tool may be broken after valves latest update. I host source servers for customers, and have been frantically searching for a fix. So far I've found that replacing the below files in orangebox/bin and hl2/bin fix it to a point, but I'm still having random server crashes. Id like to have this thread up to see if anyone else has found any other fixes.

So far I've tried:
Disabling all addons
Clean reinstall of server, even on completely different machines
Replacing the following files: and (I've put links to these files below, as they've helped somewhat)
[Image: rvzo8z.png]
I have the same problem - since pathday 24. june the servers keep crashing @start. Only an old version will start. Could it be helping to deactivate the new cpu detection function?
Ive also tried that, which made the situation better for my server with a slower processor. I used this command:
export RDTSC_FREQUENCY='2659.000000'
But if you look at the server right after it runs the benchmark, it should tell you a number like that which this command needs to be set too.
[Image: rvzo8z.png]
Im still significantly stumped. My servers went down last night, so i updated them, went to start them, and they wont even start now. Below is my server startup running.

Auto detecting CPU
Using default binary: ./srcds_linux
Server will auto-restart if there is a crash.
INFO: Located steam: ../steam
Updating server using Steam.
Checking bootstrapper version ...
Updating Installation
Checking/Installing 'Team Fortress 2 Content' version 254

Checking/Installing 'Team Fortress 2 Materials' version 125

Checking/Installing 'Base Source Shared Materials' version 8

Checking/Installing 'Base Source Shared Models' version 4

Checking/Installing 'Base Source Shared Sounds' version 4

Checking/Installing 'OB Linux Dedicated Server' version 106

HLDS installation up to date
CAsyncIOManager: 0 threads terminating. 0 reads, 0 writes, 0 deferrals.
CAsyncIOManager: 119 single object sleeps, 0 multi object sleeps
CAsyncIOManager: 0 single object alertable sleeps, 0 multi object alertable sleeps
Using breakpad minidump system
Using breakpad crash handler

Console initialized.
Game.dll loaded for "Team Fortress"
Setting breakpad minidump AppID = 440
Forcing breakpad minidump interfaces to load
Looking up breakpad interfaces from steamclient
Calling BreakpadMiniDumpSystemInit
Installing breakpad exception handler for appid(440)/version(4617)
Particles: Missing 'particles/error.pcf'
maxplayers set to 32
No '-replayserverdir' parameter found - using default replay folder.
Replay: Creating thread pool...Replay: Starting thread pool with 4 threads...
Unknown command "r_decal_cullsize"
maxplayers set to 32
Unknown command "startupmenu"
WARNING: Port 27015 was unavailable - bound to port 27017 instead
WARNING: Port 27005 was unavailable - bound to port 27007 instead
WARNING: Port 27020 was unavailable - bound to port 27022 instead
WARNING: Port 27040 was unavailable - bound to port 27042 instead
Network: IP, mode MP, dedicated Yes, ports 27017 SV / 27007 CL
ConVarRef room_type doesn't point to an existing ConVar
Executing dedicated server config file
MDLCache: Failed load of .VVD data for weapons\w_models\w_medigun.mdl
CMDLCache:: Out of memoryCMDLCache:: Out of memory
PreMinidumpCallback: updating dump comment
Add "-debug" to the ./orangebox/srcds_run command line to generate a debug.log to help with solving this problem
Tue Jul 5 02:01:40 MSD 2011: Server restart in 10 seconds
Tue Jul 5 02:01:43 MSD 2011: Server Quit
[Image: rvzo8z.png]

Forum Jump:

Users browsing this thread: 1 Guest(s)