SRCDS Steam group

Server.cfg won't work
I try to make a server for my friends to play, i can make it online but it won't matter what i put into server.cfg located at orangebox/tf/cfg.
I did everything just as here -->
Tried just to update sv_password "my personal password" and rcon_password "my personal password"
i use "" markings and tried without them. My server name is always also team fortress 2 server. Nothing i put in server.cfg changes it. Should i put server.cfg some other place? People get in to my server to play and have good time, i just want to add password to it. I use commands stated in tutorial i linked. I do everything just like it tells. I tried other server.cfg files. HELP
Paste us your server.cfg file and your start up commands and things along those lines.
Game Servers -- -- Use promocode "frag" for 15% off every month!
Everythings the same as on the link above.. Same paths, same startup commands and same cfg with password added:

// Server Name
hostname "My desired server name"

// Rcon Cvars
rcon_password "Mypassword" //Set's remote control password
sv_rcon_banpenalty 15 //Number of minutes to ban users who fail rcon authentication
sv_rcon_log 1 //Enable/disable rcon logging.
sv_rcon_maxfailures 3 //Max number of times a user can fail rcon authentication before being banned
sv_rcon_minfailures 5 //Number of times a user can fail rcon authentication in sv_rcon_minfailuretime before being banned
sv_rcon_minfailuretime 10 //Number of seconds to track failed rcon authentications

// Server Password
sv_password "My password" // Password protects server

Should I add something into startup command to get it add password?
To make sure your server.cfg is getting executed your command line should look similar to this:

srcds.exe -console -game tf +ip <ip> -port <port> +maxplayers 20 +exec server.cfg +map cp_granary

And make sure your server.cfg is in the right folder. If you do that your password should be working correctly.
Game Servers -- -- Use promocode "frag" for 15% off every month!
And that folder is orangebox/tf/cfg/server.cfg? And only in there? If that's true, then it won't work. I'm using win7 btw. runnicg cmd as admin, perhaps i'll try a .bat file.
Ok i figured it out. I changed coding, unicode to UTF-8 and it worked. Weird.

Forum Jump:

Users browsing this thread: 1 Guest(s)