SRCDS Steam group

"Host_Error: IDLLFunctions::DLLInit returned false."
I was installing a Gmod server and I had it up and running, and then I decided to install a Game mode and the game mode kept telling me it couldn't drive from the game mode's "base". So it had to derive from the regular "Base". This made the game mode not work. So I decided to re-download the whole SRCDS dedicated Files in a different folder. Then I keep getting this error when ever I launch the "Start.bat". I have Wiped this folder and re-downloaded 3 times. This Dedicated server is completely default, no addons, no game modes, nothing. I still get this error "Host_Error: IDLLFunctions:Big GrinLLInit returned false." For no reason.

Here's the Quick facts.

Not my OS, I have had CSS and A GMod server(had a GMod server working not an hour before.) work on this same OS.
Not a addon/game mode.
I have tried -verify_all
I have downloaded the default files 3 times.
I have tried updated uncountable number of times.
Windows Server 2008 R2
2 core's of a 1055T AMD 2.8Ghz
Ram 2GB 1666 DDR3

Now my Questions, I have noticed people having this problem some years back but nothing current date. Is anyone else having this problem and just not posting about it or what?

How can I possibly fix this, or is this a GMod update causing this. I would like to hear from someone who has tried downloading the server files and tried starting the server without this error. Preferably one windows 2008 server OS.

Start.bat file.
@echo off
cd b:\Gmod_Server/orangebox
srcds.exe -console -game garrysmod +map gm_construct +maxplayers 16
@echo off
cd b:\Gmod_Server\
echo This will take a long time, I would recommend you go do something else.

echo Updating/installing CS:S
hldsupdatetool -command update -game "Counter-Strike Source" -dir b:\Gmod_Server

echo Updating/installing Orange Box
hldsupdatetool -command update -game orangebox -dir b:\Gmod_Server

echo Updating/installing Garrysmod
hldsupdatetool -command update -game garrysmod -verify_all -retry -dir b:\Gmod_Server

echo Update/installation Complete
echo Your server is now ready to use!

Thanks for reading my problem.

Forum Jump:

Users browsing this thread: 1 Guest(s)