SRCDS Steam group

Segmentation fault, fresh install
Hi, kinda new here. Our dedicated server is running Debian, and the other hardware related information comes below (I can move it up here if that's preferred).

I'm trying to run Garrysmod and CS:S. After running gmod successfuly, I tried to get CS:S going, and ran into trouble with Metamod: Source. I removed EVERYTHING and started over with a fresh install of the orangebox.

Here's what I get (command simplified; doesn't matter how I run it):
Quote:colton@fromyay:~/srcds/orangebox$ ./srcds_run -game cstrike -debug
Auto detecting CPU
Using SSE2 Optimised binary.
Enabling debug mode
Server will auto-restart if there is a crash.

Console initialized.
./srcds_run: line 344: 1441 Segmentation fault (core dumped) $HL_CMD
Cannot access memory at address 0xf77e9658
Cannot access memory at address 0xff98736c
/home/colton/srcds/orangebox/debug.cmds:3: Error in sourced command file:
Cannot access memory at address 0xf77e9658
email debug.log to

Debug file:
Quote:CRASH: Wed Jun 8 00:35:15 CEST 2011
Start Line: ./srcds_i686 -game cstrike -debug
#0 0x00000000 in ?? ()
No symbol table info available.
End of Source crash report

cpuinfo (only posted one core):
Quote:colton@fromyay:~/srcds/orangebox$ cat /proc/cpuinfo
processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 15
model name : Intel® Xeon® CPU 3050 @ 2.13GHz
stepping : 2
cpu MHz : 2133.406
cache size : 2048 KB
physical id : 0
siblings : 2
core id : 0
cpu cores : 2
apicid : 0
initial apicid : 0
fpu : yes
fpu_exception : yes
cpuid level : 10
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr lahf_lm
bogomips : 4270.16
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual

It's the exact same output with garrysmod. Oh, and I have tried updating the games and hldsupdatetool.
Have you tried the -verify_all command in the hldsupdatetool?
<del>This is all I get:

PDV 1.5.1 - Glen Wiley <></del>

Nevermind, got it to verify properly. Same problems, though.
try a complete new download into an empty directory, maybe verify_all is missing something, or you still have some custom additional files there (which will not get removed by verify_all). (Linux Kernel HOWTO!)
Do not ask technical questions via PM!
As suggested, did another clean install. This time, removed the Steam directory as well as srcds. No good :[
if you are absolutely sure that you did not miss something, it leaves you two possibilities: your Linux installation is somehow screwed, or your hardware has a defect... try running a memory test first. (Linux Kernel HOWTO!)
Do not ask technical questions via PM!
Ah, well then I suppose I'll start looking up how to do that.

It's frustrating how sudden this all was. gmod ran fine, as did CS:S when I first installed them. After a reinstall (would not load metamod plugin), it suddenly stopped working - I can't imagine what might have changed in such a short time.

I'll check and see if hlds still runs fine (cs 1.6), if that's useful at all.
Back sometime after my last post, I removed everything (for probably the third time) and reinstalled. My problem was fixed, until the recent update. Now it's broken again, with apparently the same exact problem. I really doubt this is my linux environment. Almost forgot: it passed memtest fine.
Coltron did you update all your mods to the new versions when the update came out?
Game Servers -- -- Use promocode "frag" for 15% off every month!
You probably upgraded to a newer version of glibc (which is a good thing), but the Source DS guys have not released an updated binary that supports your version yet. The "solution" is to downgrade your server and complain to the Source DS guys until they compile a better-supported version. That's right: no more updates of any kind (bugfixes, security patches...), since the rest of your system will depend on that new glibc. Kind of a big deal. They really need to make a new binary.
don't raise old threads, please. (Linux Kernel HOWTO!)
Do not ask technical questions via PM!

Forum Jump:

Users browsing this thread: 1 Guest(s)