SRCDS Steam group

Another Offline SRCDS Issue
Yeah. It's one of 'those' threads again. Simply put; I'm having extreme difficulties getting my server online. All of my
attempts have failed and I've read just about every tutorial there is (including the official steampowered guide) on
port forwarding and server configuration just to assure I haven't missed anything or skimmed over anything too fast.

I know what I'm doing but I think I'm missing something extremely fundamental here. I'll try to be as brief as possible
so I don't bore you with any useless details, so here it goes.

I have all the files prepared and configured for my online SRCDS(Counter-Strike: Source)

I have configured my machine to have the following ports forwarded on my home router:
[Image: 30612999.jpg]
I get mixed results from online port checking tools. Sometimes, even port 80 will not show up but I know my
MineCraft server (port 25565) works globally even when port checker says that specific port is closed. So this
doesn't help me either. I can't tell if my ports are forwarded properly but I know that they are configured as
shown on my router so that's all I can guarantee myself.

I've also tried enabling DMZ(de-militarized zone) on my machine and completely removing my routers firewall
which doesn't show me any results. I also have no clientside virus or firewall protection. And my UAC is disabled.

My server reads that it's connection to steam servers was successful, yet when
I input the status command within both the server console and the client (game)
console it shows the local IP address:
[Image: 10902612.jpg]
I sometimes give my friends my external IP and test to see if it will add to their favourites, but again nothing.
Another way I check is by searching my server on game-monitor.

I use the following command line for startup;
start /high orangebox\srcds.exe -console -game cstrike +ip +map scoutzknivez -maxplayers 11 -autoupdate
*Also tried without +ip which doesn't seem any different and replacing my local IP with my external obviously gives me a winsock error.

My server.cfg file contains nothing out of the ordinary (portion);
sv_region 255
sv_lan 0 // DO NOT CHANGE
sv_unlag 1 // DO NOT CHANGE
sv_maxunlag .5 // DO NOT CHANGE
sv_minrate 20000 // DO NOT CHANGE
sv_maxrate 100000 // DO NOT CHANGE
sv_client_cmdrate_difference 1 // DO NOT CHANGE
sv_client_predict 1 // DO NOT CHANGE
sv_client_interpolate 1 // DO NOT CHANGE
sv_client_min_interp_ratio -1 // DO NOT CHANGE
sv_client_max_interp_ratio -1 // DO NOT CHANGE
Again, I've tried replacing my external IP with my local IP which gives me no success either.

Additional Information:
Location: Manchester, England.
ISP: British Telecom (Infinity Fibre Optic: ~40 Mbps down, ~10 Mbps up)
OS: Windows 7 64-bit SP1, 4GB, Phenom II x4 3.7 GHz

Again, if anyone can provide some solution, suggestion or recommendation- I would be greatly obliged. I haven't
had this much difficulty configuring and/or setting up a server since I changed my ISP.

Thank you,
Remove: IP

from your server.cfg

It's possible that they are conflicting with your startup line.
Looking for a game server? Visit and pick one up as low as $2.50 / mo!

Forum Jump:

Users browsing this thread: 1 Guest(s)