SRCDS Steam group

./srcds_run: line 426: 13186 Segmentation fault $HL_CMD
when i try to run my server i get this error..
./srcds_run: line 426: 13186 Segmentation fault $HL_CMD

iv'e looked everywhere for a fix but i can't find anything. I've been messing with the server allll day and it still aint working, can any one help me please?
You are not the only one having this problem. For me it came with yesterdays update.
I am pretty sure this is because the loader is not correctly running the right binary. I am trying to find information on how to force it to use what I need to stop this.

I'll post what I find.

My Hardware Specs
Dell \ 800 FSB dual xeon \ PowerEdge 1800
Intel \ 2.8 GHz 800FSB \ P4 Xeon
Generic \ 2048 MB \ DDR 400 ECC Reg
Unknown \ Onboard \ SCSI
Fujitsu \ 73GB:SCSI:Ultra320 TotalControl \ map3735nc

Redhat Enterprise Linux - OS ES 3.0

[Image: 26.png]
unfortunately I can't fix that problem, but I know how to get the server crashed Wink
in my case: as soon as any Player presses the F2 Key the server crashes with an Segmentation Fault and is restarting.

Any suggestions are really appreciated.


Instead of posting what server you have from the planet and what not, can you please specify things like, the exact command you are using, glibc version, kernel version, things like that?
[Image: userbar_wow.jpg]
starting 9/24/2006 if your problem has been solved please edit your first post and add [solved] to the begining of the title. Thanks.
I have this error too.

CRASH: Wed Feb  8 18:18:40 EET 2006
Start Line: ./srcds_i686 -game cstrike -debug +ip *.*.*.* -port 27016 +ma
p de_dust -nomaster -insecure +sv_lan 1 -maxplayers 16
Using host libthread_db library "/lib/".
Core was generated by `./srcds_i686 -game cstrike -debug +ip *.*.*.* -por
t 27016 +map de_dust -'.
Program terminated with signal 11, Segmentation fault.
#0  0x40a90a8e in ?? ()
#0  0x40a90a8e in ?? ()
End of Source crash report

console log
Auto detecting CPU
Using SSE2 Optimised binary.
Enabling debug mode
Auto-restarting the server on crash

Console initialized.
Attempted to create unknown entity type event_queue_saveload_proxy!
Game.dll loaded for "Counter-Strike: Source"
maxplayers set to 16
Club-iX SrcDS Config Succesfull Executed
Network: IP *.*.*.*, mode MP, dedicated Yes, ports 27016 SV / 27005 CL
./srcds_run: line 426: 21128 Segmentation fault      (core dumped) $HL_CMD
Cannot access memory at address 0x40014f7c
debug.cmds:3: Error in sourced command file:
Cannot access memory at address 0x40014f7c
email debug.log to
Wed Feb  8 18:18:40 EET 2006: Server restart in 10 seconds

gcc --version
gcc (GCC) 3.3.4
ldd --version
ldd (GNU libc) 2.3.2
uname -a
Linux cs3 2.4.26

I can see alex3d is running the binary, try using srcds_run if its not suing the right binary then add the switch
-binary ./srcds_i686
[Image: userbar_wow.jpg]
starting 9/24/2006 if your problem has been solved please edit your first post and add [solved] to the begining of the title. Thanks.
This action did not help me.
I will further search for reason.
I do not surrender.

If still there are actions, that it is possible to try, write me.

Can in me old Kernel ?
I had this issue too but found it was a corrupt map I was trying to start the server with. (How it got screwed I dunno) I just deleted the map and restarted the server and let it redownload the map the it worked. :/

Not sure if thats the cause for your problem but it helped me, and may help someone else Smile

Forum Jump:

Users browsing this thread: 1 Guest(s)