SRCDS Steam group

L4D Server
Alright, so my friends and I (from around the same area) like to play versus on L4D1. Yeah, I know it's old, but I still need some help on setting up a server. I think I've set everything up right.

Here are the steps I took :
1. I downloaded Left 4 Dead Dedicated Server from the Tools tab on Steam.
2. I put the launch options
Quote:-console -game left4dead -ip xxxxxxx -hostip xxxxxxx +hostport 27015 +map l4d_vs_hospital01_apartment.bsp
3. I run the the Left 4 Dead Dedicated Server from Steam.
4. I connect by looking at the "Steam Group Servers" and selecting my server's name.

But here's my problem. I want my other friends to connect, but the server is only working for me. When they try to connect to my IP, it loads and freezes. They can't connect. Is there something I'm missing? Can someone review the steps to me? Thanks!

EDIT : The IP that I put for the -ip part of the launch options was and the IP that I put for the -hostip was the IP that I found at
You must open your ports. Smile
Oh, okay. How do I open my ports? I'm not really good with all this networking business, haha. Sad

Also, what do I forward?
it mostly depends of which Router you have.?
a good site to try out first is
pick your router then pick your game (i dont know if it l4d or the steam server to choose)

I have forwarded the ports I needed for Left 4 Dead. Still the same problem. When my friends try to connect by typing "connect [insertip]", their loading just freezes and they can't connect.
Did you give them this ip? What's my ip address, create your own visitors IP image
Firewall settings?..
Yes, I gave them my IP and disabled my firewall. Anything else I should try? Sad
Is your server viewable from ?
I ran the L4D Dedicated Server tool, but still no go. Is there any way of contacting any of you so I would have an easier time getting help? Smile

EDIT : It is not viewable by
Make sure you've forwarded the ports to the IP of the computer who is hosting the server.
Did I do it right?

[Image: 21379760.png]
You've put your external IP as your LAN ip. And that is not portforwarding. Smile
Is this correct?

[Image: 48845793.png]
No. That will rather block all traffic than allowing it. Smile

Forum Jump:

Users browsing this thread: 1 Guest(s)