SRCDS Steam group

SRCDS and linux problems
I am running Fedora Core 4 via:ssh

gcc (GCC) 4.0.2 20051125 (Red Hat 4.0.2-8)
ldd (GNU libc) 2.3.5
uname - 2.6.14-1.1644_FC4smp

When I try to run srcds from a directory othere that /root/ I get errors.

Say my command line goes:

/home/srcds_1/srcds_run -console -game cstrike +map de_dust2 +maxplayers 32 +ip -port 27015 -autoupdate

then I get and error saying "invalid game type cstrike"

so I then add to the command -game /home/srcds/cstrike

the I get an error saying:

cannot execute bin/

I want to know if there are more paramiters in the srcds_run file that I need to set in order to use different directories for multiple servers.

Please help.

if you havn't, install screen

but otherwise, try running it from your srcds_1 dir and see what happens
What does screen do?

And just so that everyone knows. I only have webmin and ssh access. This machine is in California in a data center.
just lets you keep running the server after you quit the ssh

edit: to install screen its= $ yum install screen

after than you put screen -R css ./srcds_run xxxxxxx

ctrl-a-d to detach and then you can quit the ssh

if you need to attach you just log in via ssh again and type $ screen -r css
Thankyou. Works beautifully.

But I stall have to run the server in my /root/ directory or I get all those errors.

I have to run it using ./srcds_run -xxxx or /root/srcds_run -xxxx

I need help with that now. Smile

If I run it in home directory and I login as a user... then I get a "Pemission Denied" error message. Any suggestions for this?
ya... log in as root and go to the home directory of the user you want to run it as then type

# chown user srcds_1

edit: i'm assuming you installed it to the user's home dir but was just root when you installed it
Im sorry but I tried to do that but I got nothing.. I was probably doing it wrong.

my -dir is:

/home/john/srcds_1/SRCDS_CGS/ (and all my source files are in here.)

can you tell me exactly what the command should look like.. Smile

sorry for the noob questions.. thankyou for your help.
log in as root or su

# cd /home/john
# chown john srcds_1
still permission denied on that.

I ran those commands just as you put them.
Ok.. I may have fixed this whole problem...

I will post again to let you know.
Please post your fix when you get a chance. I am having the same exact problem. I am using a Debian distr.

Forum Jump:

Users browsing this thread: 1 Guest(s)