SRCDS Steam group

[resolved]My SRCDS wont work plz help
I used the code

@echo off
echo Protecting srcds from crashes...
echo If you want to close srcds, close the srcds window and type Y depending on your language followed by Enter.
title Server Watchdog
echo (%time%) srcds started.
start /wait srcds.exe -console -game garrysmod +map gm_construct +maxplayers 16
echo (%time%) WARNING: srcds closed or crashed, restarting.
goto srcds

but it wont work it crashes than restarts than crashes again than repeats this over and over. Ive searched but culdnt find the answer Sad
It flashes so quick i dont even know what the error says. I'll try to makeout what it says
[Image: compproblem.png]
I've made a srcds server before it worked fine but than i reinstalled EVERYTHING on my comp than made a new srcds server but now it doesnt seem to work
Is the watchdog located in the server folder as srcds.exe?
Yeah. why

And also without the watchdog it wont run at all.
Ill open and it closes right after.
Right click -> Run as administrator.
Looking for a game server? Visit and pick one up as low as $2.50 / mo!
(03-19-2011, 08:36 PM)loopyman Wrote:  Right click -> Run as administrator.

I think I see "Administrator" in the watchdog, not sure if that would do anything :p

Anyways, are you running any addons on your server?
Also try to launch the server with -debug
Tried running it as administrator
exact same thing happens.
and i dont have any addons right now.
-debug didnt work eitherz
(03-19-2011, 11:41 PM)supaherobomb Wrote:  Tried running it as administrator
exact same thing happens.
and i dont have any addons right now.
-debug didnt work eitherz

And are you sure that the watchdog is located in C:/srcds/orangebox/ ?
Or depends on where you installed it. Could you show us a screenshot of the folder, where the watchdog is located?
[Image: 49381521.png]
Okay try to update garrysmod agian. Smile

hldsupdatetool.exe -command update -game garrysmod -dir .
Didnt work :'(
Try to run the server as this, without the watchdog.

srcds.exe -console -game garrysmod +map gm_construct

Just open CMD and then go to the directory where srcds.exe is located.
same thing happens it opens than closes right after.
Ill try reinstalling the whole srcds folder and ill get back to u.

Also i used the tutorial on this website for the GMod server just so u know
The reinstalling did the trick thx.
Sorry or the trouble

Forum Jump:

Users browsing this thread: 1 Guest(s)