SRCDS Steam group

TF2 Beta SRCDS Crash on exec
Server OS: Windows Server 2008 32-bit
Processor: Intel Xeon CPU X3220 @ 2.40GHz
Ram: 4 GB
Game: TF2 Beta (tf_beta)
Start Up Command:
Exec Command: srcds.exe -game tf_beta -console +exec replay.cfg +map cp_gravelpit +maxplayers 24 -ip -port 27015 -tickrate 66 +fps_max 512
Update command: HldsUpdateTool.exe -command update -game "tf_beta" -dir c:\TF2Beta -verify_all
Admin Mods: None.

SRCDS Crashes on exec with error: "Could not load: replay". I have edited replay.cfg and replay_local_http.cfg to include the appropriate settings and have even replaced the +exec replay.cfg with +exec server.cfg resulting in the same error. Disabling replay in the replay.cfg results in the same error.

Upon attempting to do a fresh install, I get a "Connection reset by peer" error at about the 98% mark. Rerunning the update results in repeated attempts to download steam.ini and gameinfo.txt, but I am not confident I am getting all the correct files (the percentage counter on the left never goes above 53% on -verify all).

I am running and update without issue 2 regular team fortress 2 servers on the same machine, run out of a datacenter.
Bump Sad
Remove the "+exec replay.cfg" line and file.
Remove "+fps_max 512"

Try -game tf instead of tf_beta for the Exec command.
~ Mooga ...w00t? - on Twitter
[Image: 76561197965445574.png]
Please do not PM me for server related help
fqdn Wrote:if you've seen the any of the matrix movies, a game server is not all that different. it runs a version of the game that handles the entire world for each client connected. that's the 2 sentence explanation.
(03-18-2011, 04:48 AM)Mooga Wrote:  Remove the "+exec replay.cfg" line and file.
Remove "+fps_max 512"

Try -game tf instead of tf_beta for the Exec command.

Removing +fps_max 512, +exec replay.cfg and the file has no effect.

Using -game tf causes the srcds window to not even appear/load. I noticed one other person has posted on the steam forums with the same issue...I feel for some reason those files aren't being downloaded by the updater tool, though I dont know if there's anything server admins can do about it.

Thanks for your help.
I copied over server files from my machine that successfully ran the beta, to the server box I am hosting. The same "Could not load: replay" error occurred.

I suppose at this point it has to do with account permissions as I do not own/control the box that I host the servers out of. Running SRCDS as an administrator has no effect, possibly because the user account is listed as a user.

Forum Jump:

Users browsing this thread: 1 Guest(s)