SRCDS Steam group

Problem when trying to use new Kernel

I have been trying to install the Kernel patch by following to guide on to get 1000FPS on my source servers. I'm running CentOS 5.5 and everytime I run this;
mkinitrd /boot/initrd-

I get;
No modules available for kernel ""

After running this command prior to doing the command that gave me the error;
mkinitramfs -o /boot/initrd.img-

System Specification (If it helps):
Dell Poweredge 1950
2x Xeon Quad Core 2.0Ghz
Seagate 500GB Hard Drive

Thanks for any help and suggestions,
You don't need 1000FPS on OrangeBox. You simply need the stock FPS settings. The engine runs at multiples of 33.3, OB has 66.6 of precision, which is rounded up to 67. So you'll simply need a server FPS of 67.

“The two most common elements in the universe are hydrogen and stupidity.”

did you do "make" before running mkinitrd/mkinitramfs? (Linux Kernel HOWTO!)
Do not ask technical questions via PM!
No i assume that's my problem then?
I just tried again and it created all the right files such as the .img boot file etc. And it added it self to the GRUB boot loader. But now when it boots i get.

unmounting old /dev
unmounting old /proc
unmounting old /sys
switchroot: mount failed: No such file or directory
Kernel panic - not syncing: Attemping to kill init!
Pid: 1, comm: init Not tainted #4

Call Trace:
[<ffffffff8022f16b>] panic+0xd4/ox17e
[<ffffffff8027bafe>] handle_mm_fault+0x706/0x764

And 3 others, any ideas?
probably something went wrong with your init ramdisk. I can't help you with that, because I usually try to avoid init ramdisks. you can try the same, i.e. compile everything required for boot (disk/sata driver and file system) fixed into the kernel, so it has a [*] instead of a [M] in menuconfig. then you can install the kernel in grub without a ramdisk. that makes it actually easier, especially if you want to play around with kernel settings... (Linux Kernel HOWTO!)
Do not ask technical questions via PM!

Forum Jump:

Users browsing this thread: 1 Guest(s)