SRCDS Steam group

Fedora Core 4 Issue - Can't Connect to Server

Ok. So i got my CS Source server installed. I launch it, it comes up. I do a status, i get status. Then i try to connect from my pc via steam and/or CS and it is no where to be found.

sv_lan is set to 1

I fire up some netstat -l and I can see the UDP / TCP ports. Interesting enough, the Recv-Q starts going up as I attempt to hit the server from CS. Here is my config:

Command Line: ./srcds_run -console -game cstrike -port 27016 +ip +map de_dust +maxplayers 10

Machine Config: p3 933 512 MB Ram
gcc (GCC) 4.0.0 20050519 (Red Hat 4.0.0-8)
ldd (GNU libc) 2.3.5
uname -v: #1 Thu Jun 2 22:55:56 EDT 2005
uname -a: Linux aeon 2.6.11-1.1369_FC4 #1 Thu Jun 2 22:55:56 EDT 2005 i686 i686 i386 GNU/Linux

Network Config:
RR Cable Modem -> Linksys WRT54G Router -> Static set on the nix machine.

CS Console Data:

Console initialized.
Attempted to create unknown entity type event_queue_saveload_proxy!
Game.dll loaded for "Counter-Strike: Source"
maxplayers set to 32
maxplayers set to 10
Network: IP, mode MP, dedicated Yes, ports 27016 SV / 27005 CL
Executing dedicated server config file
Summary: 322 resources total 13.35 Mb, 19.90 % of capacity
Server logging enabled.
Server logging data to file logs/L1202053.log
L 12/02/2005 - 21:43:47: Log file started (file "logs/L1202053.log") (game "/home/alperez/srcds_l/cstrike") (version "2567")
couldn't exec banned_user.cfg
couldn't exec banned_ip.cfg
hostname: Raleigh RR CS Source
version : 2567 insecure
udp/ip :
map : de_dust at: 0 x, 0 y, 0 z
players : 0 (10 max)

# userid name uniqueid connected ping loss state adr

Lastly... After about a minute or so i get this:

cminterface.cpp (733) : Assertion Failed: m_hConnectionTCP

Help... Anyone...
I found the solution at SteamPowered's Forum!

Quoted from that forum...

Quote:Hello guys, i've found the reason for the "not response" problem :-)
The problem is located in the "srcds_i486" file, all other binary-files are okay.
I've tested them all on a p3, p4, intel Xeon, AMD and AMD64 system
and i've found a solution for the 486(intel) users
After i've renamed the "srcds_amd" to "srcds_i486" :-) the server starts with the renamed amd binary as default binary it does not look very nice, but it works

solution was found by the technical director team of

to the valve developer team: please check the i486 binary in the last update very soon

Forum Jump:

Users browsing this thread: 1 Guest(s)