SRCDS Steam group

problem with dedicated Server in Garrys Mod

Bandwidth: PING 82ms, DOWNLOAD 1.06mb/s, UPLOAD 0.42mb/s
Router: AZTECH -DSL605E
Local IP of Server:
External IP:

Port Forwarding Screen Shot:
*run dedicated server garrys mod in local ip address*
[Image: no2.jpg]
this when i start game no adjusting appear my ip become local ip

*Problem when using External Ip Address*
[Image: no3.jpg]
this i adding External Ip Address then problem come out with engine error.

- i adding external ip address in "C:\gmod\orangebox\srcds.exe console -game garrysmod -map gm_construct -maxplayers 6 - ip"

*Port Forward Setup*
[Image: 1-4.jpg]

[Image: 2-3.jpg]

[Image: 3-3.jpg]

[Image: 4-1.jpg]

[Image: 5.jpg]

[Image: 6-1.jpg]

i not sure my setup router is correct. is this problem my server cant use external IP addresss ?
Because you are behind a router and not connected to the MODEM you will not be using your external ip address.

In order to use your external, try un-connecting from your router and connecting directly to your modem.

When you do this start you game via,

cd c:\gmod\orangebox\
srcds -console -game garrysmod +map gm_construct -maxplayers 2

let me know what happens.
i not sure i going to do that because my modem combine with router. i dont have one router and one modem

you can try look it...
*here image inlarge*
I see well is an address I do not believe people can connect to. In order to start the server however to test it out without getting that error do the following,

Open command line prompt
type the following,

cd c:\gmod\orangebox\
srcds -console -game garrysmod +map gm_construct -maxplayers 2

that will start the gameserver with the Internal IP address but again I believe this option will only be LAN based.
i try do that what you say

"cd c:\gmod\orangebox\
srcds -console -game garrysmod +map gm_construct -maxplayers 8"

i change maxplayer to 8 then i wait one day (go work office), then after working offcie i came home and i saw my computer, i got result

Result Server :
[Image: no4.jpg]

That mean my server is online ? oh yeha i have problem with this one ? what that mean ?

[Image: no5.jpg]
Yes this means the server is now successfully online, and to my amazement looks like people have joined the server.

By the way this is the console version of srcds. This will use less GUI resources and allow more customization from the startup point.

- Travis
It tell whats wrong. It can't download the lua cache..

I have been searching with my famous friend, Google:!&p=11222

Hahahah and btw. i freaking loved the topic-creator's picture!!! DL'ed it and UL'ed it to my own webserver! Big Grin :

[Image: What_The_Shit.jpg]

This is only if you are using fastdl:
Slå den med jeres fiberforbindelser...

[Image: 1308107839.png]

Forum Jump:

Users browsing this thread: 1 Guest(s)