SRCDS Steam group

[solved]Permission Denied despite correct file permissions???
I'm about ready to pull my hair out.

I'm trying to set up a new Counter-Strike Source dedicated server following the guide here.

I am not a beginner to linux. I have been running it as my primary operating system for over 10 years. I am following the guide as I only install a source server every few years and I don't want to miss anything.

So here is my problem:
css@Suppository:~/srcds$ wget
--2011-01-07 21:42:03--
Connecting to||:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 3513408 (3.4M) [application/octet-stream]
Saving to: `hldsupdatetool.bin'

100%[======================================>] 3,513,408   1.05M/s   in 3.2s    

2011-01-07 21:42:06 (1.05 MB/s) - `hldsupdatetool.bin' saved [3513408/3513408]
css@Suppository:~/srcds$ chmod +x hldsupdatetool.bin
css@Suppository:~/srcds$ ./hldsupdatetool.bin
bash: ./hldsupdatetool.bin: Permission denied

I can't even execute the file as root...

The guide I linked above provided a direct link to the source binary in case of extraction problems so I downloaded that instead, and here's what I get:

css@Suppository:~/hlds$ chmod 755 steam
css@Suppository:~/hlds$ ./steam -command update -game "Counter-Strike Source" -dir .
bash: ./steam: Permission denied
css@Suppository:~/hlds$ ls -l
total 7652
-rwxr-xr-x 1 css css 7822833 2005-03-07 18:42 steam

So for some reason I am getting "Permission denied" errors trying to execute these files even with the file permissions set correctly.

I just can't seem to figure this one out. Any help would be appreciated.

Server Specs are as follows:

Server OS: Ubuntu Server 10.04.1 LTS 64bit (Linux Suppository 2.6.32-24-server #43-Ubuntu SMP Thu Sep 16 16:05:42 UTC 2010 x86_64 GNU/Linux)
Processor: AMD Athlon™ X2 Dual Core Processor 3250e stepping 02. Dual core at 1.5Ghz
Ram: 2 GB
Game(s): Trying to install Counter-Strike Source, but it doesn't matter, this occurs for all games.
Start Up Command: Don't have it installed yet. Trying to install using this command : "./steam -command update -game "Counter-Strike Source" -dir ."
Admin Mods: Unable to get to the point where you install admin mods.

I'd appreciate any help I can get!


Also worth noting. I saw this thread in which someone had a similar problem and solved it by installing ia32-libs. I double checked on my server, and ia32-libs are already installed, so this is not the same issue.
I think I figured it out.

For some odd reason it doesn't look like my server is allowing any execution of files from within the /home dir.

/home is mounted on an external eSATA storage array, and I have reviewed the fstab and everything looks normal, but it just won't allow execution there...

So, I I created a /srcds folder on the root file system and installed there instead, which is what I wanted to do, as that is the servers SSD, and should be much faster for map loads, etc.

Now I am having an AdminMod install problem, but I am going to do some research first, and if I can't figure it out, I'll start a separate thread for that...

Forum Jump:

Users browsing this thread: 1 Guest(s)