SRCDS Steam group

Setting IP of the server
Hi, im trying to set the IP of my server (in linux). First off, it tells me

"ip" = "localhost" - Overrides IP for multihomed hosts
Network: IP, mode MP, dedicated Yes, Ports 27015 SV/27005 CL

I want the IP to be the one i set in the startup script like...

./srcds_run -console -game dod +ip "blah"

but it doesnt want to @.@ how do i set it so its an internet server, basically, and not a LAN server?

Also - just a stupid side note - but the server.cfg goes in the /dod/cfg file correct?
In your server.cfg file, put "sv_lan 0"!
If your behind a firewall its what you shuld do, but dont forgett to forward the ports to the server in the router.
sv_lan 0 in server.cfg
+ip in your startline.
But if the server is with its own public ip, you should have that instead.

Good Luck :-)
You can also place the ip command in your server.cfg file. Make sure it is placed in their and not the autoexec.cfg as that will also give you the "cannot allocate udp port" error message that you receive when placing +ip XXX.XXX.XXX.XXX:XXXX in your start up parameter.

Forum Jump:

Users browsing this thread: 1 Guest(s)