SRCDS Steam group

srcds.exe - Entry Point Not Found error!
Hi all,

I have 2 issues with my server, that may or may not be linked. The first is 2 identical error messages in a row pop-up during the start up of the server. The second is that it appears to be a LAN server. People outside the LAN can view it, but unable to connect.

Here is the cmd window before the 2 errors:
Quote:Console initialized.
Steam is not active, running in -insecure mode.
Loading unsigned module server.dll
Access to secure servers is disabled.
Game.dll loaded for "Counter-Strike: Source"
maxplayers set to 20
Unknown command "r_decal_cullsize"
exec: couldn't exec banned_user.cfg
exec: couldn't exec banned_ip.cfg
maxplayers set to 20
Network: IP, mode MP, dedicated Yes, ports 27015 SV / 27005 CL
Executing dedicated server config file
Attempted to create unknown entity type info_ladder! Can't init info_ladder
Attempted to create unknown entity type info_ladder! Can't init info_ladder

Then the error that appears twice as a pop-up is:
Quote:srcds.exe - Entry Point Not Found error!
The procedure entry point PLAT_GetExecutablePath could not be located in the dynamic link libary libary tier0_s.dll.

Then after crossing off the errors, the cmd continues with:
Quote:Failed to load Steam ServiceBStartService failedServiceStart: failed to startexe
c: couldn't exec banned_user.cfg
exec: couldn't exec banned_ip.cfg
Connection to Steam servers successful.
VAC secure mode is activated.

Here's all the info from the ReadMe.

Server OS: Windows Professional 64-bit.
Processor: Intel Core2Quad Q8300 2.5GHz (
Ram: 4GB
Game(s): Counter-Strike: Source
Start Up Command: Using a shortcut with the target as:
Quote:D:\srcds\orangebox\srcds.exe -console -game cstrike -tickrate 66 -port 27015 +exec server.cfg +map cs_office +maxplayers 20
Admin Mods: None

Full Install Command:
cd \srcds
Quote:hldsupdatetool -command update -game "Counter-Strike Source" -dir C:\srcds

(Adding this, since it might be the cause of nobody being able to connect from outside)
Bandwidth: [Image: 1019820483.png]
Local IP of Server:
External IP:
Port Forwarding Screen Shot: [Image: CSSPort.jpg]
If you are hosting and playing on the same computer please read: THIS POST
If you have a non-typical home network, please put a small diagram.
Typical Home Network: [Server] --> [Router] --> [Modem] --> [Internet]

// server name
hostname "My Server"

// rcon passsword
rcon_password ""

// Server password
sv_password "sgd"

// server cvars
mp_friendlyfire 0
mp_footsteps 1
mp_autoteambalance 1
mp_autokick 0
mp_flashlight 1
mp_tkpunish 1
mp_forcecamera 1
sv_alltalk 0
sv_pausable 0
sv_cheats 0
sv_consistency 1
sv_allowupload 1
sv_allowdownload 1
sv_maxspeed 320
mp_limitteams 3
mp_hostagepenalty 0
sv_voiceenable 1
mp_allowspectators 1
mp_timelimit 60
mp_chattime 10
sv_timeout 120

// round specific cvars
mp_freezetime 6
mp_roundtime 5
mp_startmoney 800
mp_c4timer 45
mp_fraglimit 0
mp_maxrounds 0
mp_winlimit 0
mp_playerid 0
mp_spawnprotectiontime 5

// bandwidth rates/settings
sv_minrate 4000
sv_maxrate 20000
decalfrequency 60
sv_maxupdaterate 60
sv_minupdaterate 10

// server logging
log off
sv_logbans 0
sv_logecho 1
sv_logfile 1
sv_log_onefile 0

// operation
sv_lan 0
sv_region 3

// execute ban files
exec banned_user.cfg
exec banned_ip.cfg

Any help would be great!

Bump. Same error as above (after last update)

Entry Point Not Found error!
The procedure entry point PLAT_GetExecutablePath could not be located in the dynamic link libary libary tier0_s.dll.
The only thing I could think of would to be delete all the srcds binaries and then reinstall...
Looking for a game server? Visit and pick one up as low as $2.50 / mo!
I am also having this problem; under the title "Ports".

I had a couple people to prevail we couldn't figure it out.

I emailed Steam support on Saturday and Still waiting for a response.

I feel your anger.
[Image: wyn10.png]
I have the same problem, but i got my server working...

If i run it when steam isnt running. It works,
else if i runned it recently or i am running it, it popup the error message :S
Interesting observation.

I will test that too. I had noticed my DS not throwing errors 100% of the time, but thought it might have something to do with the starting map(s). I access my DS with a couple of MBP's, so I don't always have steam running on the DS system.

No error if Steam is not running on the same server as SCRDS.
I noticed something else, when i change the map on the startup window (where you can put the server name, port , etc, and the map name) and i launch the server, it show in the server list that my server doesnt have VAC running and most part of the time the server appear as 'Not responding' to my friends but not for me.
After 2 consecutive launch with the same map the server works normal again (with VAC).
Hi Shooters.

  1. Stop Steam Client and the Server.
  2. Start the server.
  3. Start the Steam Client.


See you soon,


Forum Jump:

Users browsing this thread: 1 Guest(s)