SRCDS Steam group

Nobody joins my server [l4d]
Im new in hosting l4d servers so please don't by mad at me Smile

I've got my own server server in my house(Athlon 3000+ 64bit 512Mb of RAM) and it worked worked...
Every day there was about 200 players and it was awsome Big Grin
But last few was terrible, nobody joined.
I've done few changes in the config file and i think there is a problem. The config was as simple as it can be and it worked fine, i chaneged it for something more advanced:

Now i have config more similar to my old one(but not the same):
hostname "L4D server"

rcon_password "********"
sv_lan 0
mp_disable_autokick 1
sv_cheats 0
sv_clearhinthistory 0
sv_consistency 1
sv_pausable 0
sv_search_key ""

setmaster add
setmaster add
setmaster add
setmaster add

sv_allow_lobby_connect_only 0

I've added some master servers but still nobody joins :/

The ip address is (f****** dynamic ip)

If someone could check if the server is added on the server lists or is it working or got good server config i would be very happy Smile
(sorry for my english im from poland)

I think that i know where problem is:
When server starts it gives "Unable to load Steam library."
but even if i reinstall all the stuff or delete files it still gives "Unable to load Steam library."
The OS is Debian lenny5(think that can help a bit Smile )

Please help me
Got second ("fresh" with clean OS) machine for tests, every idea will make me happy Smile
Nobody can help? The iptables are ok, ports are open but nobody joins :/ there were 3 servers and about 200 players every day, when i have changed the server.cfg file (without backing it up) the server died... Could someone check if it is online or is it added to the public lobby?(i haven't got steam...)
Please help :/

In reply to:
1. Command line to run server
2. uname -a
3. ldd -r bin/*
4. ???????
5. PROFIT!... (visit the thread to
Don't know why this post is "invisible"...

1.screen -A -m -d -S l4d1 ./srcds_run l4d -autoupdate -pingboost 3 +ip $ip +hostport 27201 +exec server.cfg +map l4d_farm01_hilltop

2.Linux serwer 2.6.26-2-amd64 #1 SMP Thu Sep 16 15:56:38 UTC 2010 x86_64 GNU/Linux

3.ldd -r bin/*
1. +ip & +hostport -> -ip & -port.
3. Not /bin directory, bin/ subdir of your server installation.
Ok i've changed the startline:
screen -A -m -d -S l4d1 ./srcds_run l4d -autoupdate -pingboost 3 [b]-ip[/b] $ip [b]-hostport[/b] 27201 +exec server1.cfg +map l4d_farm01_hilltop

ldd -r bin/*:
Try run it from root
I doesn't helps and with -ip & -hostport i cant even add the server for any of server lists because it says that "Could not request server information".
-port, not -hostport.
I had this problem a few months ago. Ironically, the only way I could find a solution was to disable both iptables and CSF. There must be a hidden port not documented that enables the master server to automatically push people to your server.

I was just messing around with L4D though, so I didn't look into this that much. I also discovered Killing Floor had a similar problem. (where people could manually connect with console, but not connect through the master server list despite the fact all the ports were opened. Disabling IPTables and CSF also solved this problem.)

If anyone finds a solution to this, I would definitely be interested.

Forum Jump:

Users browsing this thread: 1 Guest(s)