SRCDS Steam group

[RESOLVED]New HL2:DM Update Problems
Server OS: Ubuntu Server Edition 32-Bit
Processor: Intel Pentium 4, 2.4Ghz
Ram: 1GB
Game(s): HL2DM
Start Up Command: ./srcds_run -console -game hl2mp -maxplayers 20 -port 27015 -ip +map z_umizuri_p -autoupdate
Admin Mods: Removed during testing. (None)

Upon starting my server, as it finishes, I get "Unable to load Steam library" in the server console.

After that, even though sv_lan is set to 0, no users outside my LAN can connect. My server was working perfectly fine before the update, so it's not a network issue.

Upon clients joining, they get an error message that says: "LAN servers are restricted to local clients (class C)."

If you would to join the server to see for yourselves, click here.
try replacing with the real IP (Linux Kernel HOWTO!)
Do not ask technical questions via PM!
"Can't allocate server port."

With LAN IP:

"Unable to load Steam library."

Without using the -ip command:

"Unable to load Steam library."

RCon no longer works.
sorry I must have missed the "Unable to load Steam library" part... I guess some update did not completely apply to your server. Try running the update command again with the -verify_all option. (Linux Kernel HOWTO!)
Do not ask technical questions via PM!
Okay. Will do now. Hope for the best.
Unable to load Steam library.

I'm going to install it into a different directory and try.
After a brand new install, this is printed in the console:

* Unable to load Steam support library.*
* This server will operate in LAN mode only.*
Unable to load Steam library.

I'm going to try running the server as root now.
It worked running the server as root. So it's probably a permissions error somewhere.
After running it as root it worked. Then ran it as my user, it works now.

Requesting thread close.

Forum Jump:

Users browsing this thread: 1 Guest(s)