SRCDS Steam group

Alien Swarm - Setting the game private and Steam Groups not listing
Server OS: Windows 7 32-bit
Processor: Athlon 64 3000+
Ram: 2gb
Game: Alien Swarm
Start Up Command: Via the steam UI
Admin Mods: None

I'm having problems setting the server protected. I just had sv_password set, sv_steamgroup set and sv_steamgroup_exclusive 1 but still the server was swarming with random players in a minute.

Here's the complete cfg file that I'm "exec server.cfg" 'ing with no errors shown.

Quote:hostname "xxx"
rcon_password xxx
hostport 27015
sv_region 255
sv_lan 0
sv_allow_lobby_connect_only 0
sv_alltalk 1
sv_voiceenable 1
sv_cheats 0
sv_steamgroup xxx
sv_steamgroup_exclusive 1
asw_realistic_death_chatter 1
asw_ignore_need_two_player_requirement 1
sv_steamgroup_exclusive 1
sv_allow_lobby_connect_only 0

sv_forcepreload 1

mp_disable_autokick 1
sv_alternateticks 0
sv_clearhinthistory 0
sv_consistency 1
sv_pausable 0
sv_voiceenable 1
sv_cheats 0

fps_max 300

Also, the game is listed in the main menu in the steam group servers only when I'm in the same network, lan, the server is on.
I have ports 27005 and 27015 forwarded (tried range 27000 - 27050 too just to be sure). Also I can't see the game myself if I try to connect from wan, only console connecting works. Not even the invite link to the server works so I have no idea how the random ppl get there in the first place.

Please ask if I forgot to mention some information.
Somehow the steamgroup_exclusive maybe started working. At least no random ppl join now. But that might also be because the server isn't in the master list. How can I get it to list? setmasters shows me two ips, the default ones. The server can be connected to with console though.

I'd just want it to be easier for all the people in the steamgroup. It seems that it's listed in the main menu if you can see it in the server browser but can't get the server to be listed there.

Forum Jump:

Users browsing this thread: 1 Guest(s)