SRCDS Steam group

Update TF2? But I already updated!
So I've got 2 scripts that I run. One to start TF2 and one to update it.

-- start_tf2 --
echo "Starting TF2..."
cd games/orangebox/
screen -A -m -d -S tf2 ./srcds_run -game tf +ip +port 27015 +map Cp_WeLl +maxplayers 24

-- update_tf2 --
cd games
./steam -command update -game tf -dir .
cd ~
patch -p0 < objects.patch
#sed -i 's/\(MaxObjects[ \t\r\n\v\f]*\)1/\1 3/' ~/games/orangebox/tf/scripts/objects.txt

The patch part is just to allow me to build multiple sentries and dispensers by changing objects.txt back to my liking automatically. The sed line is the old way I did this, but I wanted different numbers of sentries and dispensers, so I made a patch file instead.

So I just ran the update about 1/2 an hour ago and start it up and it says "Your server needs to be restarted in order to receive the latest update.". Soooo I go and manually run the update command with -verify_all this time. Still no dice. THEN I try and do it by deleting the specific files it updated (since it was a small patch of 3 files) and it readded them and I STILL get the same issue.

What am I missing here?
Apparently steam.inf didn't update properly but it didn't realize this til I moved InstallRecord.blob files and the ~/Steam/ folder out of the way. Blargh. Why didn't -verify_all catch that?

Forum Jump:

Users browsing this thread: 1 Guest(s)