SRCDS Steam group


[CS:S] SOLVED Can't See/Join Server on Internet/Cant Join Own Game
#1
BASIC INFO
Server OS: Windows 7 X64
Processor: AMD Athalon 2 X4 620 2.6 Ghz
Ram: 4GB
Game(s): Counter Strike Source
Start Up Command:
I am currently using a shortcut:
Quote:"D:\Program Files (x86)\Valve\HLServer\orangebox\srcds.exe" -console -game cstrike -tickrate 33 -ip 192.168.1.139 -port 27016 -maxplayers 16 +map de_dust2 -autoupdate
Admin Mods: NONE
SourceMod: NONE

INSTALLING INFO
Full Install Command:
Used a shortcut:
Quote:"D:\Program Files (x86)\Valve\HLServer\HldsUpdateTool.exe" -command update -game "Counter-Strike Source" -dir . -verify_all

NETWORK AND BANDWIDTH INFO

Bandwidth: Not an Issue
Local IP of Server: 192.168.1.139
External IP: Would not like to post AT THIS TIME!
Port Forwarding Screen Shot:
[Image: 6F0v1.png]

Typical Home Network: [Server] --> [Router] --> [Internet] I live in an apartment

CONFIG ISSUES
I have attached my server.cfg file.

.cfg   server.cfg (Size: 1.4 KB / Downloads: 37)

I am trying to run a CS:S dedicated server using the tutorial given at this site. I have followed it to the letter. However, I cant seem to join my own game. It does not appear in LAN and the only way I can see it in the server list is if I manually add my internal IP.

I am behind a router and running Windows 7x64. I have disabled my anti virus and Windows firewall is always off. When my friend comes online (NOT ON LAN) I will see if he can join it. When I try to connect it just says after four attempts it cannot connect.
I have tried both 27015 and 27016 for my port.

Router Info:
I have opened ports 1200, 27000-27050. Do I need any more?

I use to run a CS server I am not sure why I am having so much trouble. I should at least be able to join my own LAN game right?

I have tried changing sv_lan 0 to 1 and tried joining and could not. Any help would be great. If you need I can upload my server.cfg.


This is not a 24/7 server I want to run. I just want to play a few matches with a friend against some bots for a few hours.

Thanks,
-Glapo

UPDATE 1
:
Thanks the Gunner the solution to joining your own game was removing the ip deceleration in the start command and my new start command is:

Quote:"D:\Program Files (x86)\Valve\HLServer\orangebox\srcds.exe" -console -game cstrike -tickrate 33 -port 27015
-maxplayers 16 +map de_dust2

I cannot see my server off of my LAN. My friends cannot see it either. We tried adding my external ip with port 27015 in favorites and got no results. Any help?

SOLUTIONS:

Can't Join Own Game- remove ip from the start up command as posted by Gunner below

Can't see server in favorites- I did not actually forward the range of my ports there is a separate tab for that in DD-WRT router panel.
Reply
#2
Get rid of the IP

I heard
Reply
#3
(08-25-2010, 05:14 AM)Gunner Wrote:  Get rid of the IP

I heard

...................... You are awesome. WORKS Big Grin. Since when is it bad to be too specific HUH! YOU ARE AWESOME. Thank you so much!

I can join the server. However, I cannot see it off of my LAN. Any help? I have no clue why I am having such a hard time doing this.

Solutions found look above
Reply
#4
use your internal ip and 27015 port in startup line
-ip "192.168.1.139" -port "27015"

use quotes on inputes in startup line commands in case some names like the default exec file contain spaces i think but it work both the ways spaces or without

and trust me i have several routes that does'nt let me see my server from external ip and port at all
only linksys support that
either way i heard about never try to connect to it using external ip it will causes extreme laggs as i heard

you should be able to see your server in lan listing with usin 27015 port

also make sure you set your internal ip to static and not dhcp enabled so at every reboot u gain the same ip so your ports won't get messed up


also never combine both dmz and single / port range forwarding to single ip that mess things up in my experiments
Reply
#5
(08-29-2010, 06:21 AM)a7m1 Wrote:  use your internal ip and 27015 port in startup line
-ip "192.168.1.139" -port "27015"

use quotes on inputes in startup line commands in case some names like the default exec file contain spaces i think but it work both the ways spaces or without

and trust me i have several routes that does'nt let me see my server from external ip and port at all
only linksys support that
either way i heard about never try to connect to it using external ip it will causes extreme laggs as i heard

you should be able to see your server in lan listing with usin 27015 port

also make sure you set your internal ip to static and not dhcp enabled so at every reboot u gain the same ip so your ports won't get messed up


also never combine both dmz and single / port range forwarding to single ip that mess things up in my experiments

Hey Thanks for the reply. I got things working by getting rid of the IP. Also I dont have DMZ enabled.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)