SRCDS Steam group


Unable to load Steam Support Library error
#1
I have been running a L4D2 server for years and for the last month it has only been running in LAN mode only. I keep getting the error

**********************************
* Unable to load Steam support library. *
* This server will operate in LAN mode only. *
**********************************

I have tried re-downloading the entire L4D2 SRCDS, using the gui with no server.cfg file, put "sv_lan 0" in config and command line, done update multiple times with "Verify_all". All of this has made no difference for the server.

I am running a dedicated server on a host with no router and full internet access. This is a Windows Server 2003 box with 2 2.4Ghz processors.

This has happened in the past and it turned out to be a faulty server package, but this time it seems as we're the only ones..... I don't see many other posts about it...

Any help is greatly appreciated
Reply
#2
Not sure but I guess there's no answer for this.....

This is the shortcut:
C:\srcds\left4dead2\srcds.exe -console -game left4dead2 -ip 204.11.33.26 -port 27016 +exec server.cfg +map c1m4_atrium -nohltv +sv_lan 0

This is the update.bat file:
hldsupdatetool -command update -game "left4dead2" -dir c:\srcds -verify_all

Server config:
hostname ">TNA< L4D2"
sv_search_key "xxxxxx"
//maxplayers 8
motd_enabled 1
sv_steamgroup xxxxxxx

// Rcon Cvars
rcon_password xxxxx

// Server Cvars
mp_disable_autokick 1 //Prevents a userid from being auto-kicked
sv_allow_wait_command 0 //Allow or disallow the wait command on clients connected to this server.
sv_alltalk 0 //Players can hear all other players, no team restrictions
sv_alternateticks 0 //If set, server only simulates entities on even numbered ticks.
sv_clearhinthistory 0 //Clear memory of server side hints displayed to the player.
sv_consistency 1 //Whether the server enforces file consistency for critical files
sv_contact cyborg11381 AT gmail DOT com
//sv_downloadurl “” //Location from which clients can download missing files

// Lan or internet play, Server region cvars
sv_lan 0 //If set to 1,Server is a lan server ( no heartbeat, no authentication, no non-class C addresses )
sv_region 0

// Server Logging
sv_log_onefile 0 //Log server information to only one file.
sv_logbans 1 //Log server bans in the server logs.
sv_logecho 0 //Echo log information to the console.
sv_logfile 1 //Log server information in the log file.
sv_logflush 0 //Flush the log file to disk on each write (slow).
sv_logsdir logs //Folder in the game directory where server logs will be stored.

//Server Rates
sv_maxcmdrate 100 //(If sv_mincmdrate is > 0), this sets the maximum value for cl_cmdrate.
//sv_unlag 1
//sv_maxunlag .5

// this will allow your server to be listed in the server browser
setmaster add 216.207.205.98:27011
setmaster add 72.165.61.153:27015
setmaster add 68.142.72.250:27011
setmaster add 72.165.61.189:27011

motdfile "mymotd.txt"
hostfile "myhost.txt"




Anybody got any ideas???
Reply
#3
Got the exact same problem since the latest update.

I even tried a complete full fresh install with no addons etc & still had the same error.

**********************************
* Unable to load Steam support library. *
* This server will operate in LAN mode only. *
**********************************

Any ideas or solutions known?
Reply
#4
Of course this has happened AGAIN with the new update.... Stupid SRCDS can't figure out how to make an update not bork a server ! ! ! and no help to fix it either.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)