SRCDS Steam group

hlds_run instead of srcds_run
What am I doing wrong? This is driving me nuts.
I am running
red hat 9 on a
2.8 GHz Celeron
with 512 RAM
and a 80 GB hd
I have DSL 1.5Mb down by 1Mb up
Everything I have read suggests that all this is more than enough to run a ds. So it has to be a short circuit between the seat and the keyboard.

I have followed 6 different tutorials and installed 6 different times but everytime I end up with the same result, a hlds_run file and not a src_run file. So I finally said to heck with it lets try running the hlds_run and see what I get. My server won't authenticate with WON and in the console it shows the server IP as and it says couldn't exec listip.cfg and couldn't exec banned.cfg and then freezes up. The only command it will respond to is exit.
In my DSL modem I have opened ports UDP 27010, 27012, 27015, 27040, and TCP 7002. Just like it says in the readme file.

What do I need to do I just want to run a counter-strike source server.
Do you even have the Source server files installed? You have to install them to a different folder from all the HL1 servers. Copy "steam" from your root hlds folder into another folder, lets say, called "source".

Once you have that folder, run ./steam like normal except use "Counter-Strike Source" as the game instead of cstrike.
./steam -command update -game "Counter-Strike Source" -dir . -username <username here> -password <password here>

After all that downloads you should have srcds_run in the root 'source' folder. I'm still installing the source server now so I'm not positive.
OK I decided to just do it again with the tutorial here.
But I am having issues with it. I can't even run the update command, I get this instead of a bunch of file flying by me being updated.

[root@localhost source]# ./steam -command update -game "Counter-Strike Source" -dir . -username liquid_fubar -password ###### -remember_password
Checking bootstrapper version ...

Create a Steam Account:
        -create <username> <password> <question> <answer>

Install or update HLDS:
        -update <game> <installdir> <username> [<password> [Y]]
         Y => remember password

View installed versions:

Everything there is exactly as it appears in my concole except the password for my steam account. This account works I have used it before. I get the same message when I try to create a new account.


./steam -command update -game "Counter-Strike Source" -dir ./ -username liquid_fubar -password ###### Y

If that doesn't work. Try adding the absolute address (long version)
It looks like the Steam file has to be updated using the old syntax before you can use the new one (which I posted).
first get a newer steam file (hldsupdatetool) then try it again.
To be (an admin), or not to be (an admin), that is the Question. steam linux install guide for cs 1.6
That is the new version of hldsupdatetool. I pulled it straight from the link on the tutorial located on this site.

link1305 the command you posted gives me the same result as the command Ard_Choile posted, which is the result that I posted above. I feel I am at an impass, all your help is greatly appreciated.

Thanks guys
Have you created the account?
Yes I have created the account. On one of my previous attempts to install this I successfully set up an account. Even when I try to set up a new account I get the same response as stated above. Its like it thinks there is a syntax error and is asking for correct input, but as far as I can tell the input is correct.
Is there something special I shoudl be doing with my network settings in redhat?
Which folder are you trying to install the server in?
I am recieving similiar results now, where I keep recieving the same results as previously posted. I am Installing into user/srcds_1
If you have an account and the old steam executable, try running
./steam -update "Counter-strike source" ./ <username> <password>

replaceing the 2 <> with your username and password, that should update teh steam executable then ask you to run it again using the new format ex: -command update -game etc..
[Image: userbar_wow.jpg]
starting 9/24/2006 if your problem has been solved please edit your first post and add [solved] to the begining of the title. Thanks.
When I try that syntax it says
updating game
connection closed by peer
take all of about 1 second.

maybe it doesnt like my steam account
what is the old syntax for creating a steam account?
I thought the executable that is referred to in the tutorial on this site would be the new executable. That is where I got the halflifeupdatetool.
Am I wrong?

Forum Jump:

Users browsing this thread: 1 Guest(s)