SRCDS Steam group

Alien Swarm is in LAN mode?
Greetings! I'm new! I'm having some troubles getting my Alien Swarm server visible on the server browser and getting people to be able to connect to it.
First off, the info!
OS: XP Home Service Pack 3 (32 bit)
Processor: Intel Pentium 4 with HT, heck I don't even know the specific model number (can't find it, don't know it, CPU-Z and windows were no help), but its 2.4 GHz, 2 threads, socket 478.
RAM: Slightly over 1GB (1.125GB I believe, have an extra 128 MB stick in there)
Games: Alien Swarm
Startup command: "C:\Documents and Settings\Server\Desktop\Alien Swarm Server\srcds.exe" -console -game swarm +map lobby -maxplayers 4 +exec server.cfg -autoupdate
I believe that should suffice.
Admin mods: none

Network info
Bandwidth: [Image: 907177412.png]
It has managed to host its fair share of Battlefield 2 servers. Never been an issue.
Router info: Linksys WRT54G2 firmware version 1.5.00
Local IP of server:
External IP:
Forwarded ports:
DMZ is enabled for the server. Ports 27005, 27006, 27015, 27016 are unblocked in windows firewall.

hostname "Learjet45's Alien Swarm Server"
rcon_password "nonyabusiness"
sv_password ""
sv_contact ""

sv_lan 0
sv_region 255
sv_allow_lobby_connect_only 0

mp_disable_autokick 1
sv_allow_wait_command 0
sv_alltalk 1
sv_alternateticks 0
sv_clearhinthistory 0
sv_consistency 1
sv_pausable 0
sv_voiceenable 1
sv_cheats 0
sv_forcepreload 1
sv_pure_kick_clients 0

exec banned_user.cfg
exec banned_ip.cfg

sv_log_onefile 0
sv_logbans 1
sv_logecho 0
sv_logfile 1
sv_logflush 0
sv_logsdir logs

sv_minrate 30000
sv_maxrate 60000
sv_minupdaterate 66
sv_maxupdaterate 101
sv_mincmdrate 66
sv_maxcmdrate 101

fps_max 101

sv_rcon_maxfailures 1
sv_rcon_minfailures 1

That should be everything. Issue is that the server is only showing up on LAN. I can see it and connect via the LAN tab of the server browser. It doesn't show up on the list of dedicated servers on the internet tab or whichever it is (the first tab), Can't see to get the issue resolved.
I am also having the same issue. From what I gather, its not setting the master servers automatically. More than likely its setting them some of the time.

My Post:

If you type setmaster in the console, you should see 2 or more servers displayed. Sometimes it will display 1. In my case it says none. Its only when it populates the master servers automatically that my server seems to show up in the server browser listings. If I add the manual setmaster commands, it will never show up in the dedicated server listings.

setmaster add
[Image: 907826872.png]
Well, I tried adding those lines to server.cfg and newmapsettings.cfg. I still can't seem to find the server on the list...

This is getting annoying Toungue I can't use the create game function in game because whenever I do, my computer crashes when we get to the end of a mission.
Hmm. I just noticed that the last second to last line is "Could not establish connection to Steam servers." I'm guessing this has something to do with it. Any ideas?

I've changed the shortcut flags to:
"C:\Documents and Settings\Server\Desktop\Alien Swarm Server\srcds.exe" -console -game swarm +map lobby -maxplayers 4 +exec server.cfg -lan 0 -autoupdate

I've also added the following lines to my server.cfg:
setmaster add

hostport 27016
are now after the ip line. Still no luck. Can't find the server in the list, only on the LAN tab.

I no longer have the unable to connect line. It now says connection to steam servers successful, but it doesn't show up on the list.
Edit: So it appears that I got it working. I tried the workaround that involves copying the 4 dlls from steam to the gameserver root, along with adding the -ip -port 27016 to the launch shortcut. But I still don't see the server in the list... I had to use the connect command in the console to connect. Any ideas?

Forum Jump:

Users browsing this thread: 1 Guest(s)