SRCDS Steam group

LAG! :(
Hello, I have the following configuration on the server:
processor : 7
vendor_id : GenuineIntel
cpu family : 6
model : 23
model name : Intel® Xeon® CPU E5440 @ 2.83GHz
stepping : 6
cpu MHz : 2826.280
cache size : 6144 KB

Cpu0 : 52.5%us, 2.3%sy, 0.0%ni, 44.2%id, 0.0%wa, 0.0%hi, 1.0%si,
Cpu1 : 90.7%us, 1.3%sy, 0.0%ni, 7.3%id, 0.0%wa, 0.0%hi, 0.7%si,
Cpu2 : 55.1%us, 2.3%sy, 0.0%ni, 41.9%id, 0.0%wa, 0.0%hi, 0.7%si,
Cpu3 : 50.3%us, 2.6%sy, 0.0%ni, 46.4%id, 0.0%wa, 0.0%hi, 0.7%si,
Cpu4 : 55.5%us, 2.3%sy, 0.0%ni, 41.2%id, 0.0%wa, 0.0%hi, 1.0%si,
Cpu5 : 20.9%us, 0.7%sy, 0.0%ni, 78.4%id, 0.0%wa, 0.0%hi, 0.0%si,
Cpu6 : 53.0%us, 2.0%sy, 0.0%ni, 44.0%id, 0.0%wa, 0.0%hi, 1.0%si,
Cpu7 : 56.0%us, 1.3%sy, 0.0%ni, 33.7%id, 0.0%wa, 0.7%hi, 8.3%si,

MemTotal: 8306700 kB
MemFree: 286052 kB
Buffers: 16432 kB
Cached: 1222736 kB
SwapCached: 0 kB
Active: 7398688 kB
Inactive: 493944 kB
HighTotal: 7466304 kB
HighFree: 9460 kB
LowTotal: 840396 kB
LowFree: 276592 kB
SwapTotal: 2031608 kB
SwapFree: 2031544 kB
Dirty: 544 kB
Writeback: 0 kB
AnonPages: 6652956 kB
Mapped: 305364 kB
Slab: 90072 kB
PageTables: 27408 kB
NFS_Unstable: 0 kB
Bounce: 0 kB
CommitLimit: 6184956 kB
Committed_AS: 9929512 kB
VmallocTotal: 116728 kB
VmallocUsed: 4040 kB
VmallocChunk: 112508 kB
HugePages_Total: 0
HugePages_Free: 0
HugePages_Rsvd: 0
Hugepagesize: 2048 kB

link(internet): 100mbps

Centos 5.4-final
Kernel 2.6.18-164.10.1.el5
GNU C Library stable release version 2.5

The server is fully with lag, rate 15 ~ 20
The server has 52 slots (DeathMatch)
Map: de_dust2

* Counter Strike Source
* Sourcemod

Does anyone know what might be happening?

CentOS sucks ! try Debian. Also your kernel is very old,try recompileing a newest one.
saintjimmygd is right!
I was reading the post
I will do the same and see if the result is positive.
but I will continue in the centos

does anyone know if the Patch is advisable for my proc? (2.6.34-sched-bfs-318.patch)

ps: sorry for english, I'm using a translator


EDIT: Can I use Timer frequency to 1000 hz? Would not it be better?
EDIT2: "Try set the Timer frequency to 1000 HZ and disable Tickless System (Dynamic Ticks). On some older systems this might lead to a better result, while especially on newer systems it probably will make things worse." Toungue
I did not realize it was you who posted.. saintjimmygd hehe

I have more than one server on the same machine
These settings are used?
(07-23-2010, 04:53 PM)memelo Wrote:  does anyone know if the Patch is advisable for my proc? (2.6.34-sched-bfs-318.patch)

try one of those described in my howto (I think you have already found it). but make sure you are running on 64 bits. that is probably much more important than debian... (Linux Kernel HOWTO!)
Do not ask technical questions via PM!
BehaartesEtwas: what you tell me about this patch?
Will it help with something?

EDIT: This "RT Kernel" is better?

This patch(2.6.34-sched-bfs-318.patch) affects something with the distribution? (CentOS)
probably not right...

PS: the system is 64bit

Your site/system is very, very good.
Thank you.
I was reading about the patch, my system is X5360 with 16GB of ram.
Is it really necessary to apply patch "RT" or "BFS"?
Or just setting the kernel configuration that shows the site of the BehaartesEtwas. Configuring and building the Kernel
the server is only for hosting HLDS, more than one server...
one has 52, 60, 30 and 22 slots
you can also try without any patch, but probably RT or BFS or ZEN is better. (Linux Kernel HOWTO!)
Do not ask technical questions via PM!
You should really try Debian 5 (Lenny), we've experienced the same issues with CentOS 5

Forum Jump:

Users browsing this thread: 1 Guest(s)