SRCDS Steam group

failed to load steam serviceservicestart: started as Windows service.
Whenever I start up my Garrysmod SRCDS server I get this error after it loads everything up.

Failed to load steam serviceservicestart: started as Windows service

I've been looking around for answers on this but often someone changes the subject before there is an answer.

- I have updated to the latest version on garrysmod, orangebox, hl2 and counter-strike source.

- I have tried re-updating and deleting the steam.ini file before
re-updating as well.

My server used to work fine all the time. The latest update is what is causing the trouble I believe. Also, the Ulx motd doesn't load anymore not a big problem but if anyone knows a fix it would be appreciated.

Attached Files
.png   pic.png (Size: 166.5 KB / Downloads: 32)
I am also getting a similar error where it sais "Failed to startCloud not establish connection to Steam servers."

then getting:
"Connection to Steam servers successful.
VAC secure mode is activated.
Connection to Steam servers lost."

When a client enters the game you get the error message: "Lua Cache couldn't be downloaded. Server is misconfigured"

This is on a fresh garrysmod srcds install.

Server OS: Windows XP SP3 32bit
Processor: AMD Phenom II X4, 3,21 GHz
Ram: 3.25 GB
Game(s): Garry's Mod
Start Up Command: srcds.exe -console -game garrysmod +map gm_construct +maxplayers 15
Admin Mods: None..
wait. Am I the only one who is getting this?..
No solution?
Subscribing to this thread for any answers.
I am experiencing the same issue.
New to server admin and trying to figure out what is the cause of this problem.
Server OS: Windows XP Professional SP3
Processor: P4 2ghz single processor
Ram: 2gigs.
Game(s): Counter Strike Source
Start Up Command: D:\CounterStrikeSource\orangebox\srcds.exe -console -game cstrike -autoupdate +maxplayers 20 +map cs_italy
Admin Mods: No mods whatsoever. Still trying to learn to run the server.
I attached a screenshot of console.
Looks like weird error, it doesn't know what failed.

With line breaks i think it should say:
Quote:Failed to load Steam Service
ServiceStart: failed to start
Connection to Steam servers successful.

UPDATE: I no longer get "Lua Cache couldn't be downloaded. Server is misconfigured", but i still get the srcds error. But it seems that the server is playable now.. I only reinstalled the server (again).

Attached Files
.png   2Aug_srcds_error.PNG (Size: 23.07 KB / Downloads: 23)
i get the same error and it all started when steam moved to installing in the new orangebox directory. I've looked for such a long time and nothing has helped. I read a post on another forum stating to delete the steamclient.dll from the orangebox\bin directory. When I did that, the failed to load steam service went away and it connected to the master servers but it also gave me the error: "Unable to load Steam support library. This server will operate in LAN mode only."

Anyone have any suggestions??? People can play if they know the IP but the server does not show up in the master list or on any sites like game-monitor or gametiger.
Vince, run hldsupdatetool it should re-download that library for you.

Forum Jump:

Users browsing this thread: 1 Guest(s)