SRCDS Steam group

srcds port
How can i make my console server use 27015 instead of 6xxxx?

My port forwarding is set to forward port 27015 on both UDP and TCP to the server machine on my lan.
Not sure I understand this one. It should be using 27015 by default.

Can you post your server.cfg (minus any passwords natch) so that we can have a look.

Aight my bad... it IS using 27015, but the outside world sees it as ... whats up with the port? i guess its my poor forwarding skills
I take it no-one can connect to it then?
i can see it and connect to it... so can other people. but if one was to type in "connect xx.xx.xx.xx", where xx.xx.xx.xx is my external ip, they wouldn't be able to connect, since css client will automatically try the 27015 port, which isnt the correct port in my case... hence the inquiry on how to fix this
Hmmm. Can you post the command line you're using to run the server and the contents of the server.cfg so I can have a look.

It's most likely your router - what make/model do you have? The D-Link's seem to have a bad rep for disobeying port forwarding commands, especially with the latest firmware.
knoid || Admin, gaming community - challenge maps - custom maps
Strangely, I have the same problem (on linux however)..

I am using Port Forwarding on my router and it it setup perfectly for port 27015, and I know the router forwards ports perfectly cos it works for web/ftp/mail/ssh/webmin and a call of duty server i used to run...

I ran netstat on my server and found some other strange ports running, so i put my server in the DMZ and used to search my server for running games. It found my server, running on port 36534... The server is also listening on 27005, 27015 and 27020?

This seems odd to me. I have tried using "-port 27015" in the server command and that makes no difference. I am running the latest steam server, I only installed it a few days ago and running the update command tells me that it's up to date.

Can anyone help me?
same thing here:
loading with server.cfg including external ip address and port of 27015. gametiger finds it at port 29842 and sometimes 29314.

IP =
Firewall = Watchguard SOHO
Custom Service = SRCDS
Incoming Filtr = Allow
Host = (my Server local IP)
Ports = UDP 1200
UDP 27000-27020
TCP 27015-27039

I can see the traffic attempting to enter ports 29842/29314.
Packet discarded from port 4281
to port 29314 (UDP)(no NAT port)

Packet discarded from port 13506
to port 29842 (UDP)(no NAT port)

I may be over 40, but I can still get you!
[Image: ausa2qf.gif]
Yep, my D-link's doing the same thing, one fellow said downgrading firmware worked for him, not surewhere to get earlier versions. I personally, with my long time of using D-link routers, think they make bad products, and their support is lacking. Linksys saves time but the wireless is wonky (according to friends), it's a tradeoff.

Forum Jump:

Users browsing this thread: 1 Guest(s)