SRCDS Steam group

Ping Spikes
My CS Source server keeps getting huge ping spikes, everyone on there except for me (I'm on the LAN) gets pings in excess of 700. I have just reinstalled the server from scratch, added nothing, and still get ping spikes. Has anyone got some magic fix for this? The server is a 1.4ghz P4 with 128megs of ram. I don't believe it has anything to do with the specs, as the old server was a 400mhz Celeron with 192megs of ram. This didnt happen until I updated the game about a month ago, been trying everything since. Any help would be appreciated.
what kernel are you running?
Linux server 2.6.10-5-686
Ubuntu Server install 5.04

Thnx, Protoss
Anyone help?
OK I just upgraded to 2.6.11-5-686, built from the source, and I still get lag. I took out most unneeded modules from it. Is there someone that can help?
I had the same problem. You might wanna increase your RAM. My Lag spikes didn't clear up until i upgraded my CPU from Xeon 1.7Ghz, to Dual Xean 2Ghz. Also, try running the nice command.

nice -n -0 ./server.script

where server.script contains your srcds command and arguements.

Worked for me....good luck

That nice -n 0 ./server.script didnt work...Still get pings of 700+. I don't see any spikes when I am watching 'top', and my old server worked just fine with 192mb of ram, with a cpu of 400mhz.
Are you running any GUI like KDE or gnome?
[Image: userbar_wow.jpg]
starting 9/24/2006 if your problem has been solved please edit your first post and add [solved] to the begining of the title. Thanks.
I run fluxbox when I need to, but never when running the Source server. I don't keep fluxbox open 24/7.
OK I think I may have solved it...It has something to do with IPv6 and the DHCP client. I guess every 5 minutes or so the server would request a new IP from my router, thus lagging like hell. I set the server to a static IP, and disabled IPv6 and it looks like the lag is gone.
Welp nvm that last post..the lag isnt gone at all. While playing a game of 1 on 1 my friend got lag of 900+, and didn't seem to be letting up. I did a 'rcon stats' and got
Quote:CPU In Out Uptime Users FPS Players
8.00 3099.42 3593.37 1407 3 333.33 2
If that helps...
can you post your server.cfg?
Quote:// server name
hostname "|EatSleepFrag|"

// server cvars
mp_friendlyfire 0
mp_footsteps 1
mp_autoteambalance 1
mp_autokick 0
mp_flashlight 1
mp_tkpunish 0
mp_forcecamera 0
sv_alltalk 1
sv_pausable 0
sv_cheats 0
sv_consistency 0
sv_allowupload 1
sv_allowdownload 1
sv_maxspeed 320
mp_limitteams 2
mp_hostagepenalty 0
sv_voiceenable 1
mp_allowspectators 1
mp_timelimit 45
mp_chattime 10
sv_timeout 65

// round specific cvars
mp_freezetime 0
mp_roundtime 6
mp_startmoney 16000
mp_c4timer 45
mp_fraglimit 0
mp_maxrounds 0
mp_winlimit 0
mp_playerid 0
mp_spawnprotectiontime 0

// bandwidth rates/settings
decalfrequency 1

// server logging
log on
sv_logbans 0
sv_logecho 0
sv_logfile 1
sv_log_onefile 0

// operation
sv_lan 0
sv_maxrate 20000
sv_minrate 15
sv_maxupdaterate 85
cl_updaterate 101
cl_cmdrate 100
fps_max 600
sv_unlag 1
That is my server.cfg.
try removing, fps_max 600, i had very strange lag issues when i tried to set host_framerate and fps_max from my server.cfg, add +fps_max 600 to your command line instead.
Still nothing. I even reinstalled Ubuntu, and upgraded to 5.10, but alas nothing Sad I am starting to lose hope in ever solving this problem.

Forum Jump:

Users browsing this thread: 1 Guest(s)