SRCDS Steam group

startup srcds with pidfile
Server OS: Debian Lenny 32-bit
Processor: intel pentium d, duo core, 3 GHz
Ram: 1gb error correcting ddr2
Game(s): cstrike
Start Up Command:
./srcds_run -console -game cstrike +map 2rooms -ticrate 33 -pidfile
echo $! >
Admin Mods: none

Here's the problem:
-> this produces no file named Googling for it gave me some ideas but none of which worked.
-> it does produce a file named but this is the pid of the keepalive script, not of the actual server instance. Killing the keepalive doesn't stop the server.

Any suggestions / patches?

It's been a while since I've tried to get this solved. In the meantime I thought of a way around by renaming the srcds binary to a unique name so I can grep for that process and kill it.

This is a dirty hack and I think it's time to get this solved!
Install/ use screen. And i've uploaded a script some time ago. You can use it for keepalive (just change some code).

Forum Jump:

Users browsing this thread: 1 Guest(s)