SRCDS Steam group

[resolved] Illegal instruction error on Ubuntu based linux
Server OS: Lucid Puppy Linux; based on Ubuntu 10.04 32-bit
Processor: Pentium III Single Core 733 MHz
Ram: 512 MB
Game(s): None yet! But Garry's Mod eventually.
Start Up Command: './steam' or './steam -command update -game orangebox -dir .'
Admin Mods: None.
Computer Mfg. Date: Year 2000

# cat /proc/cpuinfo
processor    : 0
vendor_id    : GenuineIntel
cpu family    : 6
model        : 8
model name    : Pentium III (Coppermine)
stepping    : 3
cpu MHz        : 731.570
cache size    : 256 KB
fdiv_bug    : no
hlt_bug        : no
f00f_bug    : no
coma_bug    : no
fpu        : yes
fpu_exception    : yes
cpuid level    : 2
wp        : yes
flags        : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pse36 mmx fxsr sse up
bogomips    : 1463.14
clflush size    : 32
cache_alignment    : 32
address sizes    : 36 bits physical, 32 bits virtual
power management:
# uname -a
Linux puppypc #1 SMP Mon Apr 5 12:55:04 Local time zone must be set--see zic m i686 GNU/Linux
extracting steam.tar.Z...done
# ./steam
Checking bootstrapper version ...
Getting version 36 of Steam HLDS Update Tool
Downloading. . . . . . . . . . . .
Steam Linux Client updated, please retry the command
# ./steam -command update -game orangebox -dir .
Checking bootstrapper version ...
Getting version 36 of Steam HLDS Update Tool
Illegal instruction

I get this error every time I try to download content. I've read that old CPUs that don't support sse won't work, but as you can see in /proc/cpuinfo, my comp does support sse. My comp can't run Ubuntu 9.04 (which I have a disc of) well enough to test it on normal Ubuntu.
Im just assuming you are trying to get tf2 to work?
In that case

change the
# ./steam -command update -game orangebox -dir .


./steam -command update -game "tf" -dir .

If your not trying to run tf2 then tell me what game you are.
./steam -command update -game garrysmod -dir .
It doesn't matter if I run
./steam -command update -game garrysmod -dir .
first, or
./steam -command update -game orangebox -dir .
first. Both recieve the same error.

So is it the CPU that's the problem, or is it my choice of OS?
You need SSE support on your CPU to run a source dedicated server

I don't think a P3 does
Does it need SSE2 support? Or is SSE only fine?
according to your posted /proc/cpuinfo your cpu does not support SSE2. I would have expected that SSE is enough for steam and at least the not-orangebox servers, but maybe that has changed... in any case, such old cpu will not make you a nice server. (Linux Kernel HOWTO!)
Do not ask technical questions via PM!
yes its defiantly not your OS. Personally I think linux is the best. Best of luck to you. As BehaartesEtwas said or didn't really say he suggested you get a new cpu which is also my advice.
I've found out that Valve (supposedly accidentally) compiled the Linux SRCDS with the SSE2 support on, thereby making it impossible to run on an old system that doesn't support SSE2.

Valve has made a claim that they're going to do an update to remove SSE2 only support, but it's been long in coming.

Also, If I could afford a better cpu, I'd buy one instead of trying to get this to work on my old machine. That's why I'm only intending to create a 3-4 slot server; just for me and a couple friends.

Forum Jump:

Users browsing this thread: 1 Guest(s)