SRCDS Steam group

[ SOLVED ] Block sys_ticrate Command
I want to know if there is a posibility to block this command from our customers.We are running kernel- and we want to limit all of our HLDS-based servers on ~ 500 FPS.Also,we are running GCP.
+alias sys_ticrate disabled
to the command line (untested, but I have seen something like this to work) (Linux Kernel HOWTO!)
Do not ask technical questions via PM!
It doesn't work , i can still type "amx_rcon sys_ticrate 1000" and get 1000 Fps Sad
Also,found that valve blocked the "alias" command.
Of cuorse we can run a 300 Hz kernel but we also want to offer 1000 Fps servers ...
Hey,in linux kernel,is there a posibility to set different HZ values per CORE ? That would be great ! Somethig like
-CPU 1 -1000 Hz
-CPU 2 -300 Hz etc.
no that doesn't work. but you could try using this lib:
to decrease (instead of increase) the maximum fps. the lib isn't designed for this but it might work. then you can choose different maximum fps per server. (Linux Kernel HOWTO!)
Do not ask technical questions via PM!
isn't that only for srcds ? :|
it's designed for srcds, because hlds does not work properly with fps > 1000 (it will just run faster). but apart from this "minor" problem Toungue it works with hlds as well. what I have never tested is to use it to reduce the fps... just try it out. (Linux Kernel HOWTO!)
Do not ask technical questions via PM!
Well,i found a solution.I recompiled the RT kernel just like in your tutorial but i set 300 Hz (not 1000).So now the sys_ticrate command has no (or little) effect.All that matters now is "-pingboost".With pingboost 3 in startup line we have 800-900 Fps and with pingboost2 300-400 Fps.But now i found another problem : the Fps is not quite stable Sad

taskset -c 0 ./hlds_run -game cstrike -pingboost 3 +sys_ticrate 1500 ... gives me 900 fps with drops down to 400 Sad
By the way,what happens if i set

DISABLE High Resolution Timer Support

from your HOW-TO ( ?
try it out. in fact I believe that for some reason the high resolution timer is not used on your system. else you would get 1000 fps also with HZ=100 in the kernel.

did you try the lib? (Linux Kernel HOWTO!)
Do not ask technical questions via PM!
BehaartesEtwas,i followed your tutorial on the latest kernel with RT patch 19,but i disabled High Resolution Timer Suport.And voila ! Now,with -pingboost 3 we have 800-900 Fps (regardless of the sys_ticrate command) and with -pingboost 2 we have 400-500 Fps (also regardless of the sys_ticrate command).So i can say that this is the best solution so far for limiting server fps.Smile

Forum Jump:

Users browsing this thread: 1 Guest(s)